-1
$\begingroup$

I'm a noob to this so its a noob question. When I try to extrude a model it does it 2d instead of 3d. Can someone help me? I've tried looking at videos but none show what I want.

$\endgroup$
4
  • 6
    $\begingroup$ hello, you don't give enough details about your problem, what's happening, etc... please provide details, pictures... $\endgroup$ – moonboots Jul 8 '18 at 4:53
  • $\begingroup$ If the object has any volume (i.e it's not a plane but e.g. a cube) then extruding will always be in 3D. It might seem from the current view point it's flat though. Note to use either Quad view or rotate view constantly to check how your mesh looks $\endgroup$ – Mr Zak Jul 8 '18 at 13:09
  • $\begingroup$ ...also be aware of your selection mode you're in, when editing (vertex, edge, or face). Extrusion works in all three, producing edges from disconnected vertices, and faces from edges or vertices which are connected along edges. $\endgroup$ – Robin Betts Jul 8 '18 at 16:13
  • $\begingroup$ if your model has some crazy scale on one of the axes it will look flat. $\endgroup$ – David Jul 8 '18 at 21:36
3
$\begingroup$

When extruding you can press X, Y or Z in order to force axis along which it should extrude.

You can also press E to start extruding, ESC to reset extrusion position (but it still keeps extruded geometry selected), then you can grab any of the direction axes (3 coloured arrows) that will let you move the extrusion in any direction you wish.

$\endgroup$
0
$\begingroup$

If you want en extrusion of a selection of faces in more than one direction, you can either extrude a connected region along its vertex normals, or individual faces along their own face normals .. check out the options when you hit AltE.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.