0
$\begingroup$

I am new to Blender and I am trying to bake some models in order to export them to Unity, but I always get a black image as a result after baking.

https://i.imgur.com/pd0lN0u.png

Only the land is selected and I haven't connected the image texture node to the diffuse node, since it was like that in the tutorial videos I watched, though it didn't work either when I connected them. I have a sun lamp in the scene.

Used Smart UV unwrap:

https://i.imgur.com/uNbMPvS.png

$\endgroup$
1
$\begingroup$

You have to recalculate the Normals of your ground, I guess they were messed up: Enter in Edit mode, select all and ctrl N, then Bake again.

$\endgroup$
  • $\begingroup$ I did this but then when i try to bake again it says unintialised image Land from object Land and it doesn't (tried changing the image but nothing happens) $\endgroup$ – Kresh Jul 7 '18 at 17:08
  • $\begingroup$ As I don't have your Land image in the file you've uploaded, I've created a new image in the UV/Image Editor, then change for this new image in the Image Texture node of the Node Editor, perhaps there's a problem with your Land image and you just have to create a new one? $\endgroup$ – moonboots Jul 7 '18 at 17:20
  • $\begingroup$ Thanks a lot It was a dumb mistake on my part as I didn't specify the proper image in the nodes. Now to figure out how to bake without light $\endgroup$ – Kresh Jul 7 '18 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.