24
$\begingroup$

The hotkey for mesh select mode (vertex, edge, face) while in edit mode Ctrl + Tab has been reassigned in 2.8. Is there another hotkey assigned for this?

$\endgroup$
  • 1
    $\begingroup$ I'm voting to close this question as off-topic because it is about unreleased experimental development software $\endgroup$ – Duarte Farrajota Ramos Jul 6 '18 at 19:28
  • 7
    $\begingroup$ Its just gone Alpha,...I'd say keep it open. $\endgroup$ – Mesh Jul 6 '18 at 19:35
  • $\begingroup$ Now has release candidate $\endgroup$ – Neil Jul 14 '19 at 10:10
29
$\begingroup$

1,2 and 3!

I found them by looking in the User Prefs and searching for "mode", got the feeling I will be searching here quite a lot.

enter image description here

| improve this answer | |
$\endgroup$
  • 2
    $\begingroup$ My problem with 1,2,3 is that if you are on mackbook or laptop w/o numpad, those keys switch views. so, using them as a default select_mode isn't an option. $\endgroup$ – dval Jul 15 '18 at 21:20
  • $\begingroup$ Additionally you can hold shift to combine these selection modes. $\endgroup$ – Pieter De Bie Apr 3 '19 at 17:02
10
$\begingroup$

Blender 2.80 is taking a minimal shortcut approach, that is, it is removing many existing shortcuts in the default setup.

The idea is that we have a huge number of shortcuts assigned to tasks that even long terms blender users do not know about, some tasks even have multiple key combinations assigned to them, for example you can open a file with ⎈ CtrlO or you can press F1.

You can either start with this minimal setup and add shortcuts that make sense to you, which is now easier as there are less keys with tasks pre-assigned, or you can go back to the old 2.7x shortcuts.

When you start blender you can choose which keymap to use in the splash screen.

2.80 splash screen

You can also change the keymap in the preferences.

keymap in preferences

Once you choose a keymap to use, you can save your settings so that it is used each time you start blender.

| improve this answer | |
$\endgroup$
8
$\begingroup$

I am also using a laptop with Emulate Numpad turned on. Adding the Alt modifier to 1, 2, and 3 did not do anything. I discovered that I needed to remap the numbers themselves:

  1. Click the field with the number 1 in it.
  2. Press the 1 key on your keyboard.

Because you have Emulate Numpad turned on, you will see it change to Numpad 1:

Make sure the hotkey says Numpad1

| improve this answer | |
$\endgroup$
7
$\begingroup$

You can also just add that specific shortcut back with the Call Menu command: VIEW3D_MT_edit_mesh_select_mode

enter image description here

| improve this answer | |
$\endgroup$
3
$\begingroup$

You can use ctrl+1/2/3 for vertex select, edge select, face select and shift+1/2/3 to add more than one selection mode

| improve this answer | |
$\endgroup$
  • $\begingroup$ Ctrl has no effect. 1/2/3 will toggle between the modes, and shift + 1/2/3 will add to the existing mode(s). $\endgroup$ – Subhamoy S. Jan 26 '19 at 21:50
  • $\begingroup$ Alt+1, Alt+2, and Alt+3 are available. $\endgroup$ – dval Jan 31 '19 at 10:26
2
$\begingroup$

I had the problem for a long time, by now I found the way

Preferences/Keymap/Mesh/

the first three options map the vertex, edge, face

there is 1 2 3 already there, but my keypress didn't work, so just repress the key you want to map by hand, and you will find the number changed to Numpad 1, Numpad 2, Numpad 3, in fact, I press the top line Numbers. and you will lose the scene look angle default hotkey on the real Numpad.

the cause I think is the 2.8 can't recognize my keyboard Numpad number or not.

May just my own problem.

good luck.

| improve this answer | |
$\endgroup$
1
$\begingroup$

i used this way for personal pie menu. In this case:

  1. find by name on preference/keymap >> select mode;
  2. change the name of an existing shortcut with wm.call_menu (it will automatically made a menu)
  3. press ctrl + tab to set your shortcut;
  4. add this line on the name form: VIEW3D_MT_edit_mesh_select_mode

I hope it help...

enter image description here

| improve this answer | |
$\endgroup$
1
$\begingroup$

If you want to switch back, you could go to do so by going to Edit > Preferences > Input, and then deselecting Emulate Numpad and select Default to Advanced Numeric Input.

This will let you use 1 2 and 3 for what you want to use them for (vertices, edges and faces select in Edit mode).

Screenshot

| improve this answer | |
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.