1
$\begingroup$

I'm sure someone already asked this, and yes, i googled it, but in cycles render, i do not know how to fix the transparency problem here. however, transparency works fine in blender render, so it is not my laptop not being able to support it. enter image description here

i need to get rid of the black i have a separate alpha png, but dont know how to apply it

$\endgroup$
  • 1
    $\begingroup$ if your PNG has a transparent background, plug the Image Texture with your image in the bottom entry of a Diffuse, plug this Diffuse in a Mix Shader, and plug the Mix Shader in the Material Output. Now plug a Transparent BSDF (100% white) in the top entry of the Mix Shader, and plug the Alpha output of the Image Texture in the Factor of the Mix Shader. It should work $\endgroup$ – moonboots Jul 1 '18 at 7:53
  • $\begingroup$ This might not be an answer for the general transparency problem, but there is an Addon called "MCprep" that automaticaly sets up your exportet Minecraft-World for Cycles/Blender internal... $\endgroup$ – Quacksilber Jul 1 '18 at 9:23
  • $\begingroup$ This is asked quite often. It's easier if you don't think in terms of transparency, but how to use a mask to control how two colors or shaders mix together (one of the shaders can be transparent). Read Add a transparent image on top of a material $\endgroup$ – cegaton Jul 1 '18 at 15:17
  • $\begingroup$ Another possibly related link: blender.stackexchange.com/questions/42023/… $\endgroup$ – cegaton Jul 1 '18 at 15:21
  • $\begingroup$ i already used mcprep... only works for blender render for me... $\endgroup$ – Virtual Ghost Jul 2 '18 at 7:31
1
$\begingroup$

If your PNG has a transparent background, plug the Image Texture with your image in the bottom entry of a Diffuse, plug this Diffuse in a Mix Shader, and plug the Mix Shader in the Material Output. Now plug a Transparent BSDF (100% white) in the top entry of the Mix Shader, and plug the Alpha output of the Image Texture in the Factor of the Mix Shader. It should work

enter image description here

$\endgroup$
  • $\begingroup$ does not help me at all... still showing black in the texture. $\endgroup$ – Virtual Ghost Jul 2 '18 at 7:47
  • $\begingroup$ are you sure your PNG have a transparent background? $\endgroup$ – moonboots Jul 2 '18 at 7:58
  • $\begingroup$ i didnt say that. i said i also have an alpha png to render transparent stuff $\endgroup$ – Virtual Ghost Jul 2 '18 at 9:16
  • $\begingroup$ also, i can obfuscate to get rid of the black, but its a hassle $\endgroup$ – Virtual Ghost Jul 2 '18 at 9:17
  • $\begingroup$ maybe share a file with just the object so that we can check (and pack the PNG) $\endgroup$ – moonboots Jul 2 '18 at 9:31
-3
$\begingroup$

Need to turn on "Transparent" on the render settings panel.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ The problem is with surface transparency - that setting only affects render result background transparency. $\endgroup$ – Rich Sedman Jul 1 '18 at 8:10
  • $\begingroup$ please remove this answer... i would delete it if i could $\endgroup$ – Virtual Ghost Jul 4 '18 at 1:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.