0
$\begingroup$

I have rigged head mesh and body mesh with shape keys.

I edited head mesh's basis to match with body and then make shape key value 1.0 for both mesh.

In Edit mode, two meshes match with no problem, but in object mode the head mesh deforms a little bit off.

Edit Mode: Edit Mode

Object Mode: Object Mode

I think it happens because I edited basis. How can I fix this to match both meshes after I export it?

$\endgroup$

closed as unclear what you're asking by GiantCowFilms, Scott Milner, p2or, m.ardito, Mzidare Jul 9 '18 at 16:06

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    $\begingroup$ to me, your goal is not very clear, are you trying to match two different objects? Why aren't you merging the two meshes with a ctrl J, then merging the different vertices? $\endgroup$ – moonboots Jun 30 '18 at 19:42
0
$\begingroup$

Once Basis is deleted or edited, you will have to append an earlier saved version of the model and Join as Shapes.

Hopefully, you are doing incremental saves?

The only other option I can think of is to manually match the vertex positions, but using the 3d cursor for precision:

  1. Select the body object > Edit Mode
  2. Select the vertex Shift+S > Cursor to Selected, tab to Object mode
  3. Select the head object > Edit Mode
  4. Select the matching vertex Shift+S > Selection to Cursor
  5. Repeat
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.