0
$\begingroup$

I've been trying to work on a bow and arrow and get it working inside unity. I don't have much experience with animations, but I've successfully got my characters to run, walk, idle, attack, get hit, mine rocks, cut trees etc. Today I finished rigging my bow and got it all animated. I tried exporting it as a .FBX and importing it into another project I have with the character rigged already with a pulling the bow string back and releasing. When exporting the bow, everything works great, the key-frames are perfect just like they should be but after importing into another project or even a blank blend file, my animation always adds extra key-frames and totally messes with the animation. I've spent over 2 hours trying every possible configuration I could think of inside the settings and more that definitely made no sense but I tried for the hell of it. Has this happened to anybody before? Any help, knowledge or guidance would be greatly appreciated! Thanks ahead of time and have a great weekend!

enter image description here

$\endgroup$
0
$\begingroup$

For this, you will have to do the animations in the 'dope sheet' tab.

If you still do not know, I'll show you how it works.

Basically, it is equal to timeline. But here, you can define several separate animations, and each one will have its own name.

To access the 'Dope sheet' tab, pull a new tab and select it. enter image description here

Now you will have to switch to 'action editor', because this is where you can name animations and do other things. enter image description here

Click New and type a name for your animation. enter image description here

Check the F box so that the animations are saved in your project, so you will not risk losing them when you leave the blender and open the project again another time. enter image description here

Now, do a little simple animation and export again to see if everything will work fine.

If you want to create more animations, just select + next to F.

$\endgroup$
  • $\begingroup$ Elektro Jaroski, this did not work. When exporting as I usually export, there are only 2-3 of my 9 key-frames. Also my armature no longer works and I'm missing at least 1 bone that I can see. $\endgroup$ – Jack Ritter Jun 30 '18 at 16:54
  • $\begingroup$ If you can import your .blend file so I can see what's really going on, it would be a lot better to find the solution. $\endgroup$ – Elektro Javorski Jun 30 '18 at 17:09
  • $\begingroup$ MY BLEND FILE ufile.io/aa26r $\endgroup$ – Jack Ritter Jun 30 '18 at 17:14
  • $\begingroup$ See if this animation works correctly. mediafire.com/file/1z14u5yeitflpp4/bow_editing2.fbx $\endgroup$ – Elektro Javorski Jun 30 '18 at 17:55
  • $\begingroup$ Nope, same as when I export it. The animation is broken, can no longer demonstrate inside of pose mode. Also there is still added key-frames. I don't understand it. I have no idea why this could be happening. $\endgroup$ – Jack Ritter Jun 30 '18 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.