0
$\begingroup$

I was following a tutorial on how to make realistic trees. In one part, the person makes a leaf and uses nodes to make a material. He uses a color ramp and the leaf turns black and white, but the person was able to view it in color when he clicked on Diffuse BSDF. However, I still see it as black and white! I fear I have done something wrong and if I continue without trying to fix it, I will mess up my mesh later on.

I searched everywhere on Google, but I had no luck. Here is a screenshot: enter image description here

$\endgroup$
1
$\begingroup$

With the Image texture Add transparent and Diffuse BSDF with Mix Shader. With the Alpha of image texture connect to Factor of Mix shader as shown in image.

enter image description here

Another simple way just activate Image as plane addon in Blender. Press Shift+A Mesh -> Image as plane. Navigate to the png image. Thats it Press Shift+Z to render view.

enter image description here

$\endgroup$
0
$\begingroup$

I think the person might have enabled the 'Node Wrangler' add-on. Here's how you can activate it:Activate node wrangler Then you can view real-time node updates like this : https://youtu.be/jIGJOwOjAtI?t=164

$\endgroup$
0
$\begingroup$

You connected the image texture to a ColorRamp (black/White) and that's exactly what you get. if you want to see the color just connect the image texture to the Diffuse directly.

maybe link the tutorial so we can see what is the issue exactly..

$\endgroup$
0
$\begingroup$

Ok I found the problem. I had to delete a material node and replace it with a material OUTPUT, thanks atek! enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.