In the image below I would like only the light that passes through the sphere, in this case the bright dot in the center, to be visible. Is there a way to set this up in cycles?

enter image description here

Thanks, Tyler

  • 4
    $\begingroup$ The bright light in your image is caused by Caustics but unfortunately there is no easy way (that I'm aware of) to render just the caustics from the image - and they are switched on/off via the Render properties so are not configurable via Scene or Render Layer. The only method I know that would allow you to do this would be to render the image once with Caustics enabled and again with Caustics disabled - then use the compositor to subtract the non-caustic image from the one with caustics, resulting in just the caustics left behind. If this sounds like a viable solution I can write an answer. $\endgroup$ – Rich Sedman Jun 29 '18 at 11:26
  • $\begingroup$ For caustics you would be better off not using cycles, but luxrender. $\endgroup$ – user1853 Jan 14 at 19:14
  • $\begingroup$ Or you can try Yafaray $\endgroup$ – user1853 Jan 14 at 19:23

See this .blend file. I used nodes with the Transmission Depth node and two emission shaders joined with a mix shader. Set the green one to 0 strength and it should have the desired effect. I'll post a screen shot of the node set up in a moment. (The node set up for the lamp. It's a point source directly above the glass sphere.)

Here is the node set up. node set up The green is what will go away. The pink it what will be rendered. green enabled Green disabled (strength is set to 0). green disabled

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.