0
$\begingroup$

Hi so I'm familiar with how to add images to the 3d viewport as planes. But can anyone explain how you would input a video into the 3d viewport such that you can play it in realtime?

My intent would be to create an image as a plane, add the video ontop of a section of this plane. And enable the movie to actually play (change frames and display them in the viewport) as I play from the timeline, and then use the camera to do like a 3d zooom in and down and across the plane that contains the video and back out kind of a thing. But I don't know how to make the video part work for this. I can only do it for static images atm.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ cycles or internal? $\endgroup$ – Leander Jun 25 '18 at 21:49
  • $\begingroup$ Would like to know both, but cycles probably most important if I had to choose. $\endgroup$ – kite Jun 25 '18 at 23:19
  • $\begingroup$ Cycles samples will be a problem so you'll have to reduce all bounces and use an emit material for the video texture. $\endgroup$ – 3pointedit Jun 26 '18 at 0:46
  • $\begingroup$ blender.stackexchange.com/questions/91347/… $\endgroup$ – Duarte Farrajota Ramos Jun 26 '18 at 3:33
1
$\begingroup$

Internal

  1. Add the object.
  2. Add a material.
  3. Set the material to shadeless
  4. Go to the texture tab and add a texture.
  5. Load the movie as your texture.
  6. Upon loading it enable Auto Refresh and press Match Movie Length once. The length should be updated.
  7. In the 3D viewport, switch to textured or material shading mode.
  8. In the shading options (Properties Panel N), select GLSL.

video texture


In the file you linked, the movie is playing, but you have set mapping to UV without specifying a UV Map (the object is not unwrapped). This part doesn't have anything to do with playing a movie, but with UV mapping.

Set the mapping to another type or create a UV map.

mapping coordinates

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi I was applying this to the default 2x2x2 cube on default startup. This is only working if I use the original material already loaded with the cube. If I deleted that material and made a new one with what look to be the same settings....it won't display when I do all the steps. Any ideas wut is going on? $\endgroup$ – kite Jun 28 '18 at 3:38
  • $\begingroup$ ya this is only working when I use the default cube. When I add in new cubes it doesn't work, because i have to make a new material other than the default material. $\endgroup$ – kite Jun 28 '18 at 3:43
  • $\begingroup$ If I insert a new object and apply the default material it works on the new object, and since I set the texture to that material it loads up the video automatically on the second object. For some reason there's something about the default material that is making it work. So if I deleted all my materials and objects and started with a new material the steps would NOT work for a new material. $\endgroup$ – kite Jun 28 '18 at 4:02
  • $\begingroup$ @kite I couldn't recreate your problem. I suggest you create a file from scratch where the textures don't playback and upload it to blend-exchange.giantcowfilms.com, then post the link here in the comments and I will take a look. $\endgroup$ – Leander Jun 28 '18 at 4:47
  • $\begingroup$ Steps done: 1. start with default setting .blend file. Apply steps you stated above to the existing 2x2x2 cube. 2. Upon completion, achieved the desired result. 3. duplicated the cube, went into it's material. added a new material. 4. repeated steps as you stated for this new material, result is as seen in the image above....it shows colours that change but its like a super zoomed section of the video or something weird $\endgroup$ – kite Jun 28 '18 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.