0
$\begingroup$

I'm learning Blender and Unreal side by side.

I've made a mesh and would like to use as my main character's for the game I am building. The mesh looks alright, even comes into the game with all the materials looking the way I want them and everything.

My goal is to create a skeleton that would match the Unreal skeleton enough to be able to use the animations that come stock/are so cheep on on the Unreal market.

But it seems that whatever I try, though, I don't get the right effect(s)

Method 1:

Export a Unreal mannequin into Blender. I then move the skeletal mesh to be connected the way it should be. Removing IK bones and twist bones.

(described here: dhttps://forums.unrealengine.com/development-discussion/animation/100864-tutorial-how-to-make-ue4-mannequin-in-blender)

I then have tried two versions:

A) I just parent the skeleton to the mesh and use weighted when asked.

This results in the mesh having all the bones, and I can move it all in the skeleton section of unreal. But the physics assets is a GIANT blob of blue 50x the character's size with so many volumes I don't even know where to start on trying to fix it.

And the blobs don't scale right. I can't get them to be much smaller and they just become slightly smaller spheres if I try to arrange them

B) select the skeleton, hit the create rig button and try to use that.

When I get it into Unreal, the skeleton doesn't move the mesh at all.

Method 2:

Using blender skeleton https://youtu.be/jiXwDxCZtOc Following this tutorial.

I do have a different skeleton than the person who made this does. When I create the human mesh, mine has a face and everything (no biggy, I figure, I've tried just not creating targets in unreal and I've tried removing those bones.)

My project looks different the moment I hit the rig button. I don't get the little floating orbs connected to bones.

I get one in front of the characters face. But I do have the arrows and the box around the center of gravity etc.

When I grab these and move them around The Mesh warps. Mostly.

Like grabbing the center the pants warps around but where they meet items I have joined (belt/shit) they seem completely unconnected.

(to begin with the created generated Rig is slightly larger than the original rig for some reason? If I scale from the root to .889 it's exact)

And things like the arms the bones just move through them.

Is there any help anyone can give on what I am doing wrong/how to fix this. I would appreciate it. I have no idea

(I kept getting errors when trying to post photos i have taken. I placed them in a folder on my drive here: https://drive.google.com/drive/folders/1r0mUrY40fXo9rdhwz79BWVhpymxvyjCB)

$\endgroup$
0
$\begingroup$

Found an Answer that actually works just right:

Export The UE4 mannequin.

Remove anything you dont want to use including MESH, IK bones, Twist bones.

Turn on snap and set it to verticies. Then grab ends of bones that are in the wrong positions. Move them using the axis arrows onto the correct bones. Save it for next time as it's own file

Next bring in your mesh. Scale appropriately for unreal In object mode, select the skeleton. Press shift+C so that you scale from origin. Scale it to your mesh.

Turn on the mirror x and move bones as needed.

In object mode, select the mesh and skeleton and press CTRL+P set them by weight when asked.

Go into weight mode and fix all the crazy stuff it will do for whatever reason. Export to unreal.

In unreal make sure you dont choose a skeletal mesh during import. Open the UE4 skeleton. Get to the rigging options and set it to the humanoid rig

On your skeleton do the same thing.

Go find whatever animation you want, right click on it. Select Animation re target asset, and in the process just choose your skeleton.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.