5
$\begingroup$

Blender v2.79.


Let's say I have to extrude all faces of this planar construction containing two edges not included in faces, and one isolated vertex:

enter image description here

In this object, there are not hidden vertices, edges or faces:

enter image description here


If I select all faces in Face-Select mode, the result (after extrusion of the selection) is this one:

enter image description here

The orphan edges have been selected, which isn't what I expected since it is not possible to select the edges manually (e.g. by using Border-Select) in this mode. Looks like a bug to me.


But if I select all edges in Edge-Select mode, then switch to Face-Select mode, the result is this one:

enter image description here

The edges are not kept selected. This behavior seems compliant to the documentation about Select modes:

When switching modes in an “ascendant” way [...] the selected parts will still be selected if they form a complete element in the new mode.


Another strange result: Select All in Vertex-Select mode, switch to Face-Select and back to Vertex-Select:

enter image description here

Only one edge is kept selected as well as the isolated vertex. Seems completely buggy.


Anybody with a clear view of this? What is the correct way to select all complete faces for the extrusion?

$\endgroup$
3
  • 1
    $\begingroup$ There is probably a zero sized face there with overlapping vertex. Try removing doubles $\endgroup$ Jun 24, 2018 at 15:37
  • $\begingroup$ @DuarteFarrajotaRamos: I've updated the question, adding the number of faces reported by Blender. Nothing is hidden or co-located (the object is a plane where some faces and edges have been removed). $\endgroup$
    – mins
    Jun 24, 2018 at 17:15
  • $\begingroup$ Do you have a file to take a look at? As it stands, I would say select one element, no matter whether it is a Vert, Edge or Face and Select Linked by pressing L with your mouse over your target or Ctrl + L if you are elsewhere. $\endgroup$
    – Ben
    Feb 5, 2019 at 13:45

1 Answer 1

0
$\begingroup$

I'm not sure why the isolated vertex still gets selected when you come back in Vertex select mode but there may be a good reason for it since that behavior is kept on the new versions of Blender.

But there is a way to select all the faces without selecting isolated edges or vertices and it's Select Faces by Sides (Faces by sides in newer versions) :

enter image description here

It will select all the 4 sided faces by default but you have options for it after you click :

enter image description here

You can change the number of vertices to 3 and change the type to Greater than if you want to select all the faces including n-gons. This will only select faces with 4 vertices and more. If you want to also select triangles, you redo that process once with options set to Greater than 3 and redo it again with Equal to 3.

If you do this in face select mode, you will have all the faces but not isolated edges and vertices.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.