0
$\begingroup$

Hello i am trying to make a bump map but when ever i try to paint the brush gives me a ugly grainy look and i can't figure this out, i tried in a new project and it does the same thing enter image description here

I checked for all those things but nothing works...

enter image description here enter image description here

$\endgroup$
  • $\begingroup$ When you created your image texture in the UV Map area did you choose a high enough resolution? $\endgroup$ – icYou520 Jun 22 '18 at 18:04
  • $\begingroup$ Do not plug blue output socket into grey input socket. It might work the other way around but definitely not this way. In your case do not plug output of Bump node into Displacement input - if you want bump then plug output of Bump node into shader (Diffuse, Principled, whatever). If you want displacement then use output from image node (and ColorRamp / Math node to control it) $\endgroup$ – Mr Zak Jun 22 '18 at 18:26
  • $\begingroup$ For the resolution i did 1045x1045, 2000x2000, and 10000x10000 and all have the same grainy look and for the nodes i did use a shader between bump and output before and i have the same result i added new pics for proofs, the problem lays elsewhere... $\endgroup$ – Hootlook Jun 22 '18 at 19:46
  • $\begingroup$ The problem will be present if you use node inputs and outputs wrongly. There probably are other problems but why not solve this one first? What did you try to prove with new screenshot of Glossy shader plugged into Displacement input socket? Indeed it will work as crazy as it does but it only shows what I mentioned in the previous comment - do not plug data from neither blue or green output sockets into grey input socket - it will never work this way. See blender.stackexchange.com/a/102521/1245 $\endgroup$ – Mr Zak Jun 22 '18 at 20:06
  • $\begingroup$ Yes it was indeed the issue i did mindlessly this node configuration following this tutorial youtube.com/watch?v=ktsyL2Kp5bQ&t=610s i dont know if i did it wrong but i did it back the simple way as Nathan told bellow and it worked perfectly Thanks a lot ! $\endgroup$ – Hootlook Jun 22 '18 at 20:43
1
$\begingroup$

I'm just rewriting this whole answer i response to your edits, which reveal that the problem is with your node setup.

There are two (or more) ways to do one bump. One is to use the displacement output with a material with bump displacement enabled. The other is to use a bump map node to distort a normal and feed that into a shader. Usually, not both (although there can be times for that as well.)

The easier, more typical way to do it is via displacement output. Displacement expects a value. Not a shader. But you're plugging the output from a glossy BSDF into displacement. That doesn't make any sense.

Here's proper node setup for bump mapping. The image is 32 bit, which I recommend for bump textures, and I've just drawn manually, in UV edit paint mode, with brushes at default settings other than size. Notice that to modulate the bump map, I've run it through a multiply (math) node, rather than using a bump node. Although it can be a bad idea to run nodes from color to value, here it's fine, as it's just a grayscale image.

enter image description here

$\endgroup$
  • $\begingroup$ I AM working in Cycles and i did put the image in non-color data, i tried to check the 32 bit float and i guess it did look i a little better but sadly it is not the problem and the zoom has nothing to do with this because it is grainy in every angles and with any resolution of map oddly enough it seems that some faces looks better (see edit) but it is still ugly, thanks though :( $\endgroup$ – Hootlook Jun 22 '18 at 19:52
  • $\begingroup$ See edit made in light of your new screenshots. $\endgroup$ – Nathan Jun 22 '18 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.