4
$\begingroup$

While I look on my model by shift+z (in viewport) it looks good: Good looking model. Render without wired connections to the center

But when I render same scene out it looks like this: Something wrong.

I think this is caused by wrong topology, but still - in preview-mode it looks good, can I do something to make render like 'preview render'?

There is photo of the topology: topo

$\endgroup$
11
$\begingroup$

After pressing random buttons, and trying to fix mesh - successfully i did it! There was problem with my mesh - gaps caused mirror modifier, and some other things.

There is how I fixed it:

At first I was searching for something wired in mesh, found not connected edges, so I selected them.selecting edges

And scaled them down. pressed s + x (axis of scaling) + entered 0 on keyboard connecting edges

After scaling them together i removed doubles by selecting all edges press two times a then click w > Remove Doubles parsing together enter image description here

In the end, with selected mesh I pressed Mesh>Clean up>Split Concave Faces... clean up

And Voilà!

fin :)

$\endgroup$
3
$\begingroup$

It does look a topology issue. And the most likely cause is a subdivision surface modifier that has different values for render and preview. Set them to the same value and see if your new render matches your new preview.

The topology issue is either than those faces are not sufficiently planar or aren't adequately controlled with control loops. The way that you structured the central circles, you virtually have a megapole, and the fact that it's not really, not quite a pole doesn't matter. But megapoles are fine, provided their component faces are coplanar, including coplanar control loops.

$\endgroup$
  • $\begingroup$ Thanks for the answer! Unfortunately, I have not used subsurface modifier in this project, although I will keep your protip in mind. :) $\endgroup$ – gadas_ Jun 22 '18 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.