0
$\begingroup$

I have yet another issue with my learning.

You can see my node setup and render image on the screenshot.enter image description here

I have created my material in Substance Painter trial version and the normal was baked from high poly to low poly. The render in Substance painter look fine (from my beginner point of view) but the bake turned horrible and the edges lines are visible even on the blender render.

But as you can see on the next picture the bake did not end up as intended: Visible Edges lines on sleeves and lost fabric detail on some places (like on the back part of my mesh)enter image description here

On the last picture you can see how it should have turned out (changed the color darker so the result is visible) AS you you can see the normal map is visible properly same with the arms fabric details (minus the body fabric detail missing). THE THING IS!: TO achieve this I had to use a diffuse, normal and specular map all at the same time in the game engine which adds to complexity of my mesh. Another problem with this approach is that people running on low settings cant see a normal map and specular map, ending up with plain diffuse.

When I used the baked map it looked plain and the normal map details werent there almost at all. ** strong textMy question is: what did I do wrong? Is it the lightning? Other settings? IS blender capable of baking a clean and nice single map from normal + specular? Why am I getting that ugly seam in the middle where the front pieces join? I bake my textures at 4096 x 4095 pixel and SP and Blender - then lower it to 2048 . In SP i use pbr-spec-gloss setting (from yt guide) Any help is appreciated! **enter image description here

Edit: Cropped the last image.

enter image description here

$\endgroup$
  • $\begingroup$ You should avoid images that would make this NSFW.. lot of people use SE in work environments for help. $\endgroup$ – Jaroslav Jerryno Novotny Jun 21 '18 at 22:17
  • 2
    $\begingroup$ Did you bake this with flat shading and then use in Blender with smooth shading? $\endgroup$ – Jaroslav Jerryno Novotny Jun 21 '18 at 22:19
  • $\begingroup$ @JaroslavJerrynoNovotny Thank you for your reply. When I imported the mesh in Blender I applied smooth shading. Then I have duplicated it, applied multiresolution and sculpted it. So both of them should be smooth shaded. $\endgroup$ – Waffle Jun 22 '18 at 21:19
  • $\begingroup$ bold Possible fix on lines which bake with the low poly is applying multiresolution but the bake time is horrible :( bold $\endgroup$ – Waffle Jun 22 '18 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.