3
$\begingroup$

Just installed Zorin OS (a Linux distrubution) and installed Blender. I am running this Linux alongside Windows 10. So I go to the system tab in Blender and see that my GPU is not listed!

enter image description here

Why is my Nvidia GTX 1050 not showing up in the system tab? Also Blender is super laggy for some reason, could it be connected?

$\endgroup$
2
  • 1
    $\begingroup$ yes, it is connected, most likely driver issue. $\endgroup$ Jun 20, 2018 at 14:39
  • 2
    $\begingroup$ In linux you need to use the proprietary drivers for the GPU, they don't come installed by default. You will have to google that yourself. $\endgroup$
    – user1853
    Jun 20, 2018 at 17:20

5 Answers 5

5
$\begingroup$

You need to install nvidia-cuda-toolkit because blender uses this toolkit in order to drive your nvidia card.

apt-get install nvidia-cuda-toolkit

You should also make sure that your nvidia card is cuda compatible.

blender docs related to GPU.

list of nvidia graphics cards compatible with CUDA

$\endgroup$
1
$\begingroup$

I had the same problem, asked and answered here.

It was a CUDA issue. The method described in Debian docs didn't install properly and I needed to purge everything and download/install CUDA manually from scratch.

$\endgroup$
0
$\begingroup$

You could try installing the latest available graphics drivers for linux by nvidia, since cuda is supported on the 1050 mobile

Edit: I just checked your OS and since it's based on Ubuntu, you might be able to download nvidia's drivers for ubuntu

$\endgroup$
0
$\begingroup$

How you get nVidia drivers and blender support.

  • Follow what [C. Vergnaud][1] said because they are absolutely right! But I'd suggest going to [https://developer.nvidia.com/cuda-downloads][2] and then choose your distribution.
  • After choosing your distribution choose your version.
  • choose your installation type.
  • If you have non-free rpm fusion or your respective non-free repo for your distribution; make sure to remove the drivers so they don't clash.
  • follow the install instructions on the cuda website
  • reboot you just updated your kernel; *it's good practice*
  • I have Fedora so the command I needed was: `dnf -y install cuda-toolkit-11-7-11.7.0-1.x86_64`
  • You will also need to `nvidia-settings` or it won't be installed and if you have multiple monitors they will not both work till `nvidia-settings` is installed.
  • Do whatever installs the cuda-toolkit for your system!

  • Driver installation: Now you need to install the drivers: `dnf install cuda-drivers-515.43.04-1.x86_64` remember to run: `dnf remove xorg-x11-drv-nvidia-cuda-libs-3:510.68.02-1.fc36.x86_64`
  • **Congratulations!** You should now have CUDA installed.

    For further reading and information on CUDA installation: https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

$\endgroup$
1
  • $\begingroup$ Is there someone that can check why some links and formatting aren't working? $\endgroup$ May 22 at 21:39
-2
$\begingroup$

The GTX 1050 mobile series lack a feature called "cuda".

If you have a laptop with a 1050, it will not work.

If you have a desktop with a 1050, it should work, but you have a different problem.

$\endgroup$
2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.