4
$\begingroup$

I'm making an old dusty attic render and I've come across a bit of a problem. (Or several) I'm using 300 samples and the Denoiser, and as you can see in the following picture the rays are not showing very well in the render but they are in the preview, this I could live with, but would still like help and tips on why it is doing that.. What is more, I have a sun lamp on the right side of the model and the rays are coming out on the left side where there is less if any light. My sun lamp is a 5 in emission value and the size is 1, and the light bounces are 1024. What is going on!? My work and info here:

$\endgroup$
  • $\begingroup$ Don't use a sun lamp, or if you use a sun lamp use a mesh around the scene and add volume scatter as volume to it and use it as a volumetric domain. Read this: volmetric lighting not working and atmospheric lighting in cycles $\endgroup$ – cegaton Jun 20 '18 at 13:39
  • $\begingroup$ I've done all those things and it doesn't work. This place is usually my last resort. The volumetric's are already held within a cube and I've already tried with mesh lighting. Is there somthing horribly wrong? $\endgroup$ – ParallelMayhem Jun 20 '18 at 13:46
  • $\begingroup$ Bring up the value of the light try like 5000, also, are you using any glass shader on the window? $\endgroup$ – cegaton Jun 20 '18 at 14:08
  • $\begingroup$ @cegaton The problem wasn't to do with anything in those links. Please can un-[duplicate] this so I can answer it. Thank you. $\endgroup$ – ParallelMayhem Jun 20 '18 at 14:09
  • 2
    $\begingroup$ Possible duplicate of blender.stackexchange.com/questions/68410/… $\endgroup$ – cegaton Jun 20 '18 at 14:24
2
$\begingroup$

In order to have volumetrics work with a sun lamp you need to create a box around the scene and have it use volume scatter.

enter image description here

Volumetric lighting will not work with a sun lamp and volume scatter used in the world settings (read: Volume Scatter in World makes the sky turn black).

If you are using a window, then the default glass material will not allow for direct light to go thorough. You need to modify the glass material with a node setup like this:

enter image description here

(read: How can I make a more realistic glass shader? and How to illuminate the darkness inside glass objects in Cycles?)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.