1
$\begingroup$

I am trying to export from Blender to Collada .dae and seems that textures are not exported

Here it is a video with the steps

https://drive.google.com/file/d/11ELOeZovAhHoxm92P1poLjDk5EUdXZ8l/view?usp=sharing

What am I missing?

$\endgroup$
5
  • $\begingroup$ try to uncheck the "Only Selected UV map" checkbox $\endgroup$
    – Tak
    Commented Jun 20, 2018 at 14:40
  • $\begingroup$ tried, same result -> no texture exported, only the mesh $\endgroup$
    – Duna
    Commented Jun 20, 2018 at 19:30
  • $\begingroup$ here it is blender project: drive.google.com/file/d/1JESub-RWzdYmicfQB6IMWnuy6P4Iksli/… $\endgroup$
    – Duna
    Commented Jun 20, 2018 at 20:13
  • 1
    $\begingroup$ really weird. Copying of textures seems to only work if the image is selected under the in the uv editor when blender renderer is selected (even if switching back to cycles afterwards). $\endgroup$
    – PeterT
    Commented Jun 21, 2018 at 10:48
  • 1
    $\begingroup$ I'll try to make a small writeup as an answer after work if no-else already did it by then but for me setting the textures in the blender render worked. Both setting it as a uv texture and setting it as a material texture but not as a pure node texture. $\endgroup$
    – PeterT
    Commented Jun 21, 2018 at 11:24

1 Answer 1

1
$\begingroup$

The default Blender Exporter does not seem to be able to embed textures into Collada *.dae files (as of 2.79b).

It can however save textures alongside Collada files. To do that it has two sources of texture files.

Materials as texture source

See this video if you want to see it in action.

This is used when you select Materials in the Texture Options section of the Collada Export dialog.

Exporter Texture Options, Materials selected

The steps you need to make sure the texure is set, do the following:

  1. Be sure that you are in Blender Render or Blender Game mode (you can switch back to another renderer after you set the texture)
    1a. Select your object and go into the textures tab of the Properties Panel
  2. make sure that you are editing the textures of the material
  3. add at least one texture of type Image (you can add multiple textures and all will get saved)
  4. set the image for the texture

Steps to set Material Texture

UV Texture as texture source

See this video if you want to see it in action.

This is used when you select UV Textures in the Texture Options section of the Collada Export dialog.

Exporter Texture Options, UV Texture selected

The steps you need to make sure the texure is set, do the following:

  1. Be sure that you are in Blender Render or Blender Game mode (you can switch back to another renderer after you set the texture)
  2. Select your object and go into edit mode
  3. open a UV/Image Editor panel and set the image you want to export as the texuture (you can switch back into object mode and this image will persist as the one that will be exported).

Steps to set UV Texture

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .