0
$\begingroup$

I have

A character with softbody (and ik armature if you are wondering),A wall,Collision enable

The character deforms itself on the wall as i want but some of the mesh still passes through the wall.

This would not be a problem but the fact is that my wall is a transparent glass and i do not want anything passing trough it since it kills the effect i want to make.

I tried a lot of tweaking with softbody(since tutorials are non existant) but a small part of the mesh still passes through no matter what.

To put it more simply , how to make a wall that cannot be penetrated by anything , all other things are secondary.

$\endgroup$
  • 1
    $\begingroup$ At the moment this question is too vague to answer - we need to know more of how this is set up - preferably with screenshots, etc of the mesh, the setup, what’s going wrong, etc - as much as you can provide. In addition it would also be good if you could provide a simplified .blend file to make it easier for someone to replicate your situation (but this should not be instead of the additional detail). $\endgroup$ – Rich Sedman Jun 18 '18 at 13:04
  • $\begingroup$ I should have put it more simply , how to make a wall that cannot be penetrated by anything , other things are secondary $\endgroup$ – Mai Sasaki Jun 18 '18 at 13:14
  • 1
    $\begingroup$ The blender physics simulation doesn’t work with absolutes, only forces - give something enough velocity or enough force and it will pass through a surface. However, there are some simple general things you could try - in particular, make the simulation work with smaller intervals so forces and velocities are proportionally smaller. This can be achieved by increasing the ‘Steps per second’ setting for the simulation. If you can provide a more specific example of your situation I can try and provide a more specific answer. $\endgroup$ – Rich Sedman Jun 18 '18 at 13:30
3
$\begingroup$

The blender physics simulation doesn’t work with absolutes, only forces so it is not possible to give a mesh a property that will absolutely prevent anything penetrating - give something enough velocity or enough force and it will pass through a surface.

However, there are some simple general things you could try - in particular, make the simulation work with smaller intervals so that forces and velocities are proportionally smaller. This should result in the collision having an effect before the impactor manages to get through. This can be achieved by increasing the ‘Steps per second’ setting for the simulation. For very fast simulations or extreme forces (such as a soft body string wrapping around another mesh) you may need to increase the steps per second by orders of magnitude (perhaps from 60 to 6000 or more). Increasing the steps will provide a more accurate simulation at the expense of requiring more simulation CPU time.

Other options are to ensure your Normals are set correctly and to adjust the collision bounds (eg, Soft Body settings) to be appropriate to teh mesh. For example, see How to get the physics engine to wraps a string around the moving part of a motor constraint

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.