0
$\begingroup$

It shows a very thin lines at edges after I uv-mapped a cube into a 3x2 grid env-mapping as shown below:

enter image description here enter image description here

By right it should not show the thin lines and the texture should go smoothly between faces. I also make sure there's no extra spaces between the uv vertices in uv mapping editor by setting the uv vertex into exact x and y position. Why does it still have the thin lines after all these?

Add-on:

  1. I'm using Blender internal GLSL rendering.
  2. After rendering in image, the lines still visible. The lines appear at all edges.
  3. After I export fbx and use it in unity3D, it has the same issue as well.

Source file: skybox.blend

$\endgroup$
  • $\begingroup$ are the lines also visible in the final render? do you use blender internal or cycles render? Do the lines appear on all edges, or just the ones that lay on the border of the uv-sapce? (please edit your question and add more information, this will make it more likely, that you get a fast and focused answer). $\endgroup$ – yann Jun 17 '18 at 14:38
  • $\begingroup$ hi @yann, yup i updated my question. I'm using Blender internal GLSL rendering. After rendering in image, the lines still visible. The lines appear at all edges. After I export fbx and use it in Unity3D, it has the same issue as well. $\endgroup$ – kkl Jun 17 '18 at 14:49
  • $\begingroup$ that sounds strange. could you provide your .blend file and the skybox so we can have a look? Blends can be uploaded here: blend-exchange.giantcowfilms.com $\endgroup$ – yann Jun 17 '18 at 14:52
  • $\begingroup$ I uploaded to google drive and updated in my question. U could try download n see $\endgroup$ – kkl Jun 17 '18 at 14:55
2
$\begingroup$

You are running into Blender interpolating your texture a little, so that when it "smoothes" the pixels of the texture, it's grabbing the next texture over and averaging with the local color, creating an off color along your UV edges.

You can:

  • Turn off interpolation, but beware, this will make the texture a little more pixely.
  • Unpack your UV's a little and put an "average color" in the space in between so it interpolates better. It looks like you baked this texture, you also might want to try just re-baking after doing this.

[Edit]

Downloading and messing with the file showed that interpolation was not the issue here (or at least turning it off doesn't help). It seems that the UV's overlap so perfectly that the line is an artifact of that. Fixing it is simple:

  1. Go to the UV editor, press a until all UV's are selected.
  2. Switch pivot type to "Individual Origins"
  3. press s and scale all the uv's down a hair, doesn't take much

selecting all uvs with individual origins on

Should be fixed after that.

fixed skybox

$\endgroup$
  • $\begingroup$ I turned off interpolation and it's still not working. Is the interpolation under Texture Tab -> Image Sampling? $\endgroup$ – kkl Jun 18 '18 at 1:57
  • $\begingroup$ Yeah, that's the one. I downloaded your file and found another thing to try, editing answer. $\endgroup$ – Kirbinator Jun 18 '18 at 5:07
  • $\begingroup$ Wow~ it works! Why does it happen that way? By right, uv shud be at the exact position to work, right? $\endgroup$ – kkl Jun 18 '18 at 6:24
  • $\begingroup$ I re-read your answer. I think I got the idea. Didn't know putting uv vertex in exact position causes overlap. Thanks for your help thumb up $\endgroup$ – kkl Jun 18 '18 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.