0
$\begingroup$

I am trying to map a high resolution bump map on a UV sphere, I am using a UV map, and I get this result:

rendered moon

What causes the renderer to make these huge blobs? This should be a moon, far away and big (distance is about 500, size is 300 blender units), my bump map is 3840 x 2160 Pixels TIF file (I got the same result with a half resolution bump map, too), UV-mapped to the sphere. Mesh is set to smooth, Subsurf is set to 4 subdivisions, and the node setup is as follows:

Nodes

Mapping (if I map the bump map to the color of the diffuse shader, it does not get pixelated): UV Mapping

What am I doing wrong?

Thanks for the help.

$\endgroup$
  • $\begingroup$ Could you show the unwrapping you did? one thing I can think of could be that it's mapping only a very small part of the sphere $\endgroup$ – Luke S Jun 15 '18 at 17:39
  • 2
    $\begingroup$ the strength of 500 kills the detail on the map. Try looking into the the experimental features to displace your mesh $\endgroup$ – Sidar Jun 15 '18 at 17:47
  • 2
    $\begingroup$ Setting the Image texture to non-color should help to.. But what Sidar says, search for micro displacement and adaptive subsurf. $\endgroup$ – S.Visser Jun 15 '18 at 18:41
  • $\begingroup$ Enable smooth shading. $\endgroup$ – user1853 Jun 15 '18 at 19:34
  • $\begingroup$ @LukeS I have added the UV wrapping as an image. $\endgroup$ – Nice Micro Jun 16 '18 at 0:19
1
$\begingroup$

I have figured it out. The subsurf for rendering was accidentally switched off when baking the bump map.

Thanks for all your inputs!

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.