0
$\begingroup$

So I accidentally deleted the armature modifier and when I go to make another one, my object warps. When I try un-checking vertex groups, the armature will line up with the object again but I cant use it for animation. So how do I line up the armature and mesh with keeping vertex groups checked?

Before adding armature modifier enter image description here

After adding armature modifier enter image description here

$\endgroup$
1
$\begingroup$

To fix this follow the below steps:

  1. Select your mesh
  2. Hit ctrl+A and choose apply Scale
  3. Do same step 2 and apply location and rotation
  4. Select your armature
  5. Switch to Pose mode
  6. Hit Space Bar and choose "Apply Pose as Rest Pose"
  7. Select Mesh then select armature and hit ctrl+P
  8. Parent with automatic weighting

It will be working fine as shown below:

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ So when I did step 6, there was no option to apply Scale. The only option was Play Recorded Animation. $\endgroup$ – Jbchmbrs Jun 20 '18 at 4:09
  • $\begingroup$ @Bionicman30 Sorry, I made a typo mistake in step 6. Answer updated. $\endgroup$ – Tak Jun 20 '18 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.