2
$\begingroup$

I'm noticing a significant difference between when my objects are observable in the 3D View and when the objects are rendered.

Both objects have a material with toon settings and each have materials (incorrectly?) added to the object. the human mesh has separate textures for the head and body. The sword and the human mesh both have mapping > coordinate set to UV and Mapping > Map set to UVMap, however only the head texture seems to show up properly, and the sword texture doesn't show up at all.

3D View

Rendered view

Blend file

$\endgroup$
1
$\begingroup$

You just can not see it because of bad lighting. The highlights and shadows are just much more apparent than the texture color.

Move your lamps around and you will see that the texture is actually there. The body textures however are missing from the file you uploaded.
enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Aha, very cool, glad to see the sword is actually working. Thanks! Erm, do you have any idea why the blend file wouldn't include the models 2nd texture? $\endgroup$ – Stephen Schroeder Jun 9 '14 at 16:47
  • $\begingroup$ Have you clicked 'File'->'External Data'->'Pack All Into .blend'? This should usualy pack all external textures into the .blend file. If the first texture was created inside Blender, it might have been already saved internally. $\endgroup$ – maddin45 Jun 9 '14 at 17:18
  • $\begingroup$ I had not! This new download link seems to have the texture correctly: pasteall.org/blend/29710 . Any idea why the body texture is so warped during rendering? $\endgroup$ – Stephen Schroeder Jun 10 '14 at 0:53
  • $\begingroup$ @StephenSchroeder I'm not sure what you mean.. If it's not directly related, perhaps you could ask it as a new question? $\endgroup$ – gandalf3 Jun 10 '14 at 2:11
  • $\begingroup$ In the original I posted that only the head is showing up properly in render- the body and sword weren't. Although as maddin pointed out, the sword was fine, but just not well lit. The Body texture still isnt rendered properly $\endgroup$ – Stephen Schroeder Jun 10 '14 at 3:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.