Consider the following script block:

import bpy
wm = bpy.context.window_manager    # get window manager
_defaultkm = wm.keyconfigs.default.keymaps    # get default keymap

# try retrieving the keymap_item for the view3d.move operator
# unfortunately, keymap_items at register() time is always empty
_move = _defaultkm['3D View'].keymap_items.get('view3d.move')
_move.active = False    # disable that item

It's purpose is to disable a specific shortcut which is shipped with Blender. If you run this in the Text Editor within a Blender session, it works as I wished and disables one of the standard keymap items.

However, my issue is that I'd like to run that code within the register() function of an Add-on. Within that function, _defaultkm will hold a valid Python object, but keymap_items contains no items at all and get() always returns None, causing the last line of the code to fail. It's worth noting that this fails on all different tricks of retrieving keymaps (such as the one mentioned here), it seems as if I can only access my own Add-on keymaps from within the module registration code.

Is there a way to circumvent this?

Edit

I tried a solution using a persistent frame change handler, hooked up to the load_post event. Still, I was unable to access and change the keymap from there, the issue is the same.

  • Not 100% sure what your issue is, started from scratch and it's working well. I can enable and disable Shift+MMB as expected: gist.github.com/p2or/fea39e610552b80b40533fc99934b772 – p2or Jun 21 at 13:31
  • @p2or Thanks for your gist, it works indeed as expected. However, if I copy/paste it into my own add-on, the keymap again is reported as empty. The only fundamental difference I can make out is that my add-on is a multifile one, which registers itself using register_module(__name__). Your solution might still be working for me, as I can put an extra add-on into the startup section, so it auto-loads. – aliasguru Jun 21 at 14:00
  • @p2or ok, it's not the multifile thing. With your add-on, I get the same error. It works when the user activates it in the Add-ons manager, but if you hit Save User Settings, close Blender and re-open, the same issue arises. – aliasguru Jun 21 at 14:11
  • @p2or the error message is Exception in module register(): 'D:\_PREFS_REFACTOR_\_REFACTOR_\\scripts\\addons\\blender-deactivate-shift-MMB.py' Traceback (most recent call last): File "C:\blender-git\build_windows_Full_x64_vc15_Release\bin\Release\2.80\scripts\modules\addon_utils.py", line 363, in enable mod.register() File "D:_PREFS_REFACTOR__REFACTOR_\scripts\addons\blender-deactivate-shift-MMB.py", line 21, in register wm.keyconfigs.default.keymaps['3D View'].keymap_items['view3d.move'].active = False KeyError: 'bpy_prop_collection[key]: key "view3d.move" not found' – aliasguru Jun 21 at 14:11
  • 1
    Yeah you are right, KeyMap("3D View") collection is empty for whatever reason . However, you can overwrite the existing one by assigning view3d.rotate operator: gist.github.com/p2or/0969e9981aeec63551e8f0b02e0c7d55 (to make it work at least) @aliasguru. – p2or Jun 21 at 16:16

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.