0
$\begingroup$

Some one please help me. I am creating a character for my unity game but the problem is that when i do weight paint of strength of 0.1 it act like 1.0 strength. It solved by adding corrective smooth modifier but unity does not support corrective smooth modifier so some one please help me. [THANKS IN ADVANCE].help me please I will very thankful.

$\endgroup$
0
$\begingroup$

In Unity vertex weights are normalized, meaning the sum of all weights for each vertex has to be 1. (It might also be the blender converter/exporter that does that, I don't know)

So if the 0.1 weight is the only weight applied, it will become 1. You should add 0.9 weight to another bone (probably the root-bone) to fix it.

$\endgroup$
4
  • $\begingroup$ So it means if i add 0.9 weight to root bone then it will work fine. And can you please tell me what is root bone i dont know about root bone. And thank you very much for your answer $\endgroup$ Jun 14 '18 at 10:53
  • $\begingroup$ The root bone is just the top most bone in the hierarchy, any transformation on it effects all other bones in the hierarchy (usually it isn't really used in any animation). Any vertex in your mesh that you don't want animated should have a 1.0 weight on this bone. In a humanoid character this is usually located at the pelvis (but not always), sometimes at ground level. $\endgroup$
    – Stef
    Jun 14 '18 at 13:03
  • $\begingroup$ Now all bones are working fine except upper arm bone and foot. Foot and Upper arm joint strength is 0.4 but act like 0.1. And it works perfect with corrective smooth modifier but unity does not support this modifier so is there any other way to get the effect of corrective smooth modifier to my mesh for unity and without this modifier my character look very ugly and very hard edges. Please help me $\endgroup$ Jun 14 '18 at 16:06
  • $\begingroup$ I don't know what the corrective smooth modifier is. But if it is something you can apply (and it remains correct after applying), then Unity should be able to import it correctly. An other things, there's a setting you should use when painting weights: "Auto Normalize", you should keep that on, it ensures the sum of all weights for a single vertex is always 1 $\endgroup$
    – Stef
    Jun 19 '18 at 9:11
1
$\begingroup$

If you start with a blank weight paint, as soon as the weight is more than 0 it will seem like the verts go strength 1 to the bone you are painting.

To fix this simply select you pelvis, paint your entire skin red so the vertex are weighted to the pelvis instead of nothing.

Then start painting the skin for the legs etc. and the paint "strength 1" issue was gone in my case.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.