0
$\begingroup$

This texture shows up fine on objects in material view. It is using a Geometry node set to position as the vector input for the texture nodes being used, so my understanding is the objects don't need to be unwrapped. I tried multiplying it in case under rendered lighting it was just too subtle. But it's still either not there or invisible. What's wrong?

Edit: After rebuilding some things and tweaking nodes, the problem is still there. So this time I'm posting the file. I'm also replacing the image with the latest version of the material. Only the displacement nodes are shown below, as I don't think the surface nodes could be the issue.

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Alright, it seems to be the bottom RGB Curves node. I'm trying rebuilding it. $\endgroup$ – kim holder Jun 13 '18 at 18:06
  • $\begingroup$ Replace Mix shader with MixRGB node. For now you put color output into shader input and then put shader output into color input. This isn't correct way. $\endgroup$ – Mr Zak Jun 13 '18 at 22:18
  • $\begingroup$ Possible duplicate of: Getting “experimental” true displacement to work( $\endgroup$ – cegaton Jun 13 '18 at 22:57
2
$\begingroup$

Don't use a mix shader node to mix RGB information.

enter image description here

The input for shaders and RGB information is quite different and cannot be mixed randomly. Read:

Cycles - (Shader) Nodes - inputs outputs - What are the exact data types?

and

Cycles - (Shader) Nodes - inputs outputs - What are the exact data types?

Real displacement is avaliable as an experimental feature only, So you need to enable "experimental" in the feature set and set the displacement to "true" or "both" in the materials section.

enter image description here

Read: Getting "experimental" true displacement to work

And the last, and most important piece, is that the plane needs some subdivisions for the displacement to work. A plane with just 4 vertices is not going to work for what you need, so in edit mode add a few subdivisions to the mesh.

enter image description here

$\endgroup$
  • $\begingroup$ The step I've been missing for using true displacement is baking it so the polygon count doesn't make it impractical except for maybe rendered images. I didn't think it was possible to bake it. I've found this tutorial video and i'm trying to adapt it now. $\endgroup$ – kim holder Jun 16 '18 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.