My Blender doesn't render textures in Cycles anymore. It worked before but if I now create a new project and apply a texture to an object it just gets rendered in a color present in the texture (see image).

I tried:
* restarting
* creating new prject
* using different texture format (png/jpeg)
* Changed render device (CPU/GPU)

enter image description here

I'm sure I didn't change any settings. I hope it's just something really simple I forgot :D

Thanks in avance for your help =)


1 Answer 1


You need to UV unwrap an object before an image texture will show up.

Here's a quick refresher on how it's done:

  1. Select the object and hit TAB to enter edit mode
  2. Change the selection mode to edges
  3. Select all of your 'seam' edges
  4. Hit Ctrl+E to bring up the edge menu and click 'Mark Seam'
  5. Select all edges in the object by hitting 'A'
  6. Hit 'U' to bring up the UV mapping menu
  7. Select your unwrapping method. 'Unwrap' is the quickest

If your UV/Image editor window is open, you should be able to see the unwrapped object. From there you can mess with its position, rotation, and shape.

Hope this helps! enter image description here


Not the answer you're looking for? Browse other questions tagged .