0
$\begingroup$

I wanted to add an image to a plane. Here is what I tried:

  • Created a new plane
  • Added a new material and added a texture
  • Selected .png

and this is what I get

enter image description here

And this is what is shown in the preview:

enter image description here

Why am I getting the diagonal pattern? And why is it applied by default?

$\endgroup$
  • 1
    $\begingroup$ Possible duplicate of How to map an Image on a plane manually? $\endgroup$ – cegaton Jun 12 '18 at 16:33
  • $\begingroup$ @cegaton Edited the title $\endgroup$ – Saravanabalagi Ramachandran Jun 12 '18 at 17:03
  • $\begingroup$ Are you using Cycles? Have you unwrapped the plane? $\endgroup$ – Dontwalk Jun 12 '18 at 17:07
  • 1
    $\begingroup$ Read the link. What you are missing are mapping coordinates. The most precise way to map an image is using UV maps. $\endgroup$ – cegaton Jun 12 '18 at 17:07
  • $\begingroup$ But isn't it stupid to have diagonally rotated repeating pattern applied by default in the absence of an explicit UV map? $\endgroup$ – Saravanabalagi Ramachandran Jun 12 '18 at 17:36
1
$\begingroup$

Enable "Import Images as Planes add-on" that ships with Blender, and try importing the image directly already mapped that way - it helps avoid weird problems that occur. I use it even to do cutaways later.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.