0
$\begingroup$

I got to the point on my first image (.obj) on Blender where I'm ready to render.
However while the correct colours are showing in the 3D window, it's only rendering in grey. I've been through a few forums but can't seem to find anything that fixes the issue.

Render - Before

Render - After

$\endgroup$
  • 2
    $\begingroup$ Show a screenshot of material you are using on that scene. I have a feeling it might not have texture applied anywhere on the material. $\endgroup$ – internetofmine Jun 12 '18 at 6:27
  • 2
    $\begingroup$ Most likely it's the Material override on the Render Layer. This allows you to specify a material to use for everything within that render layer. Check the Render Layer properties Material setting and ensure it is unset. See blender.stackexchange.com/a/50317/29586 $\endgroup$ – Rich Sedman Jun 12 '18 at 9:34
  • $\begingroup$ Thanks Rich, I've tried following that suggestion but unfortunately it hasn't done the trick. $\endgroup$ – Rich_75 Jun 12 '18 at 10:51
  • $\begingroup$ Make sure the Output is not set to BW, next to the output file format in the Render tab. Just seen you are using Blender internal, not sure where that setting is outside of Cycles. $\endgroup$ – rob Jun 12 '18 at 12:28
  • $\begingroup$ Try rendering in cycles.If not working please post your blender file. $\endgroup$ – Arif Bukhari Jun 12 '18 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.