9
$\begingroup$

I was trying to make a really low poly flower, basically using 2D planes and applying textures with an alpha channel (Targa, 32 bit).

However when doing the UV mapping and applying the texture as usual doesn't yield the expected results. The render either shows the image with the alpha being white, or it doesn't show anything at all (an empty/completely transparent square).

I've tried several settings, but without any results. If I drag the "alpha" down to 0, it makes the whole texture transparent which is not what I want. I've tried selecting Z transparency, and also Mask, but nothing. Is there something I'm missing? It'd be nice to know the basic workflow to get it to work.

$\endgroup$
  • $\begingroup$ If maddin45's suggestion still doesn't solve it, could you upload the .blend and or some screenshots? $\endgroup$ – gandalf3 Jun 6 '14 at 23:58
  • $\begingroup$ @gandalf3 Ehm there is no blend, I didn't save anything because it wasn't much work. It's a simple plane, unwrapped, create material, then create texture for it, and load a texture (targa 32 bit) with an image having an alpha channel/mask. That's it. :D I was still starting. For the image I got one from CGTexturers > Nature > Flowers. :) $\endgroup$ – Alenanno Jun 7 '14 at 7:48
  • $\begingroup$ Also load the image into the UV Image editor and check that the alpha is present and that Blender can interpret it as transparent. $\endgroup$ – 3pointedit Jun 15 '14 at 10:48
  • $\begingroup$ Yes it's interpreting it as transparent. I see the texture in the 3D view but the transparent areas are white. And when I render it, everything is white. However in the Texture and Materials panels, I see the alpha. $\endgroup$ – Alenanno Jun 16 '14 at 9:13
  • $\begingroup$ Here's a working file. Is there is anything which seems different from yours? $\endgroup$ – gandalf3 Jun 18 '14 at 1:19
8
$\begingroup$

Enabling Z-transparency and setting the alpha of the material to '0' was correct but you also have to tell Blender that the texture should affect the alpha channel:

enter image description here

$\endgroup$
  • $\begingroup$ I had checked that too which is why I didn't know what else to do. I'll try again tomorrow to see what happens and let you know. $\endgroup$ – Alenanno Jun 6 '14 at 23:24
  • $\begingroup$ Nope, still nothing. :( $\endgroup$ – Alenanno Jun 7 '14 at 8:01
  • 1
    $\begingroup$ This helped me, thanks! And if you see the transparency as grey color, there is also a transparency box to check on the "object" properties (forum.unity3d.com/threads/…) In my case, I worked on a MakeHuman DAE export. $\endgroup$ – baptx May 31 '15 at 21:40
2
$\begingroup$

Addition to maddin45's answer: set the Alpha value in Z Transparency to zero. You may also want to set Specular value to zero, otherwise specular highlights will show up on transparent parts of the faces.

$\endgroup$
2
$\begingroup$

If you are using Cycles render, you have to combine a diffuse and a transparent or Holdout shader( depending on your needs and situation) with a mix shader. Put the output of your alpha image as a factor in the mix shader, this way the whites of your alpha image will display the diffuse shader and the blacks will show the transparent shader or Holdout. Use Holdout if you want to retain your alpha in render also.

$\endgroup$
  • $\begingroup$ I'm using Blender render but thanks anyways! It can still be useful if someone else comes over here and uses Cycles... or if I switch to it. :P $\endgroup$ – Alenanno Jun 15 '14 at 16:07
1
$\begingroup$

On the texture panel, changing the mapping from 'generated' to 'UV' while doing everything else on here looks like it fixes what happens when you turn the alpha all the way down to zero.

$\endgroup$
  • $\begingroup$ I wasn't UV unwrapping but now I have and nothing happens. I mean, I see the texture in the 3D view, but not when I render. $\endgroup$ – Alenanno Jun 16 '14 at 9:12
  • $\begingroup$ Try adding a hemi lamp or get a point lamp to shine in front of the faces of the flower facing the camera. Also, check the UV's, they should be spaced out covering parts of the texture - if they're squashed together the texture will end up not showing up. $\endgroup$ – rdv Jun 17 '14 at 3:56

protected by David Jul 29 '15 at 16:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.