1
$\begingroup$

Why does my model show patches of light when the light source, a sun, is pointing away from it? Light pointing up I'm working on a 24 hr hillshading animation. I use the rotation of the sun to represent the angle of light on the earth (in object rotation properties this is simply Y: 90 - altitude, Z: 90 - azimuth). So at sunrise / sunset the light source is pointing straight on the model from the side, 90 degrees. Beyond this (nighttime) the light source is pointing away from the model, up into nothingness. I figured this would leave my model in the dark, but it doesn't.

At the sun's nadir, which for my location on the summer solstice, the sun is pointing at 124 degrees up into nothingness but my model still has patches of light hitting it.

Hillshading at night You can see patches of light on the mountains near the top of the image.

I'm using cycles. I have a glossy material combined with a water mask but I tried turning that off and it didn't change anything.

Edit: it is not world illumination. That made it darker but the patches of light still exist. Nadir darker

From viewing up close I can see that my mountains are simply too steep. They are steeper than the angle of light coming at them, so the edge is not blocking the light.

Lit up at the edge

I thought having my sun above my model would prevent the underside from being lit up but it does not.

Edit: this was not a world lighting issue. Ambient light is key for this render. When the sun is just below the horizon it's not instantly black. The difference between that and my problem are there were signs of direct light.

Solved the issue, see below. Simply needed to block the light.

$\endgroup$
2
$\begingroup$

I made a plane big enough to block out light coming from below. That fixed it.

It does not matter where you place your sun in the model. If it points up, it will light the bottom of the model even if it's above the model.

$\endgroup$
1
$\begingroup$

Most likely that light is coming from the World.

In the world settings check the settings for Surface. To turn off any "ambient" light, make the surface completely black.

Or remove any nodes that might be attached.

enter image description here

Or bring the strength to Zero.

Also, make sure that you are not using ambient occlusion.

enter image description here

see: What is lighting my scene?

$\endgroup$
  • $\begingroup$ It's not that, it made it darker but the light patches still exist. I will edit my original comment to show that. $\endgroup$ – jfact0ry Jun 9 '18 at 23:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.