0
$\begingroup$

can somebody help me please? I just started animating in Blender and I've been walled hard by something I can't seem to be able to fix. I've looked and looked around forums and youtube to no avail, I still cannot fix it.

I created a rig, joined it to a mesh and set 4 IK bones (for hands and feet). Everything works perfectly so far. Until I try to animate it... I tried animating without IK first and it works perfectly, everytime I select all the bones and create a keyframe, it works. But when I use IK, the IK bones ALWAYS stay in the same place. They change the starting keyframe and everything, only the rotation of the bones will be recorded.

I'm attaching a screencap to demonstrate it.

enter image description here

See, the first keyframe had the model in a standing position with his arms down, then I jump a few frames, change his pose, press A to select all bones, I to create a new keyframe and suddenly the first keyframe pose also has the goddamn arm lifted in this position!!! As I said only the rotation changes, everytime I move the IK bone it affects every other frame and the model stays like that.

I've tried absolutely everything, still can't fix it and it's driving me crazy. When I disable the IK, it works, so I'm certain the root of the problem lies there.

GIF:

https://i.imgur.com/4T8kd9W.mp4

As you can see in the first frame his arm is down, when I create a second frame in a different pose and I go back to the first frame, his arm has changed...

If anyone can help me I would appreciate it a lot because I'm getting desperate :(

Thank you very much.

$\endgroup$
8
  • $\begingroup$ How are you setting the keyframe? (In order to key translation, you have to be in the 3d view, press i and choose Loc or LocRot. $\endgroup$
    – Leander
    Commented Jun 8, 2018 at 15:42
  • $\begingroup$ That's what I do, I select the bones and press I twice. I've tried Loc, LocRot and every other option. The underlying problem is that everytime I move the IK bone, the model changes in every frame and sets that new position as the default/initial, even if I don't record the keyframe. $\endgroup$
    – user57594
    Commented Jun 8, 2018 at 15:52
  • $\begingroup$ Upload your file to blend-exchange, this will make it easier to identify the problem. $\endgroup$
    – Leander
    Commented Jun 8, 2018 at 16:19
  • $\begingroup$ Hey man thanks for your help. Blend exchange gets stuck while uploading... I uploaded it to WeTransfer instead. Here it is: we.tl/fbj1NRKEr2 $\endgroup$
    – user57594
    Commented Jun 8, 2018 at 18:24
  • $\begingroup$ you have two bones overlapping: your hand and the IK controller, so maybe you select the hand instead of the IK controller. Anyway your rigging is weird for different other reasons ;) $\endgroup$
    – moonboots
    Commented Jun 8, 2018 at 18:49

1 Answer 1

0
$\begingroup$

Turns out that you have to select the "Visual" options in the "Insert Keyframe Menu". As in, "Virtual Location", "Visual Rotation" or "Visual LocRotScale". I was just selecting all the bones and pressing "i" twice out of bad habit.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .