4
$\begingroup$

Before and After Screenshot

I made a breakable object and the simulation is fine. But when I bake the simulation all the pieces of the breakable object just stack in the same place in space.

The pieces are driven by a cube the first 60 frames, then the simulation makes the rest.

.blend in a zip file: https://copy.com/qo3Rx2dNz0xn

$\endgroup$
  • $\begingroup$ Could you upload your .blend or some screenshots? $\endgroup$ – gandalf3 Jun 6 '14 at 0:07
  • $\begingroup$ Hi, thanks for viewing my question, here is a link for the blend file you require, is a zip file: copy.com/qo3Rx2dNz0xn $\endgroup$ – Fersen Jun 6 '14 at 14:20
3
$\begingroup$

I found the answer.

  • First, the steps that caused the problem:

    After breaking the object using the cell fracture addon, I needed the physics of all the 700 pieces to be driven by an animation (they where parented to a cube which has keyframes to make everything "fall" in one piece).
    Then I keyframed the physics of one piece (1), but there where like 700 objects that I wanted to have that same behavior so to copy those keyframes I read that I just needed to link the animation data as I did (2).

  • How I found the problem:

    An action was shared linked by 757 objects (3).

  • Solution:

    So I selected my group of pieces, hit U to unlink the animation data (4) and then I baked the animation and everythig was almost fine. I didn't knew why but I simply had to unparent all the shards.

Step by Step explanation

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.