1
$\begingroup$

I have tried to make blender faster by using my Nvidia GeForce GPU in the user preferences window and under the render options in the properties window.user preferences set on GPUrender option is on GPU But I can see in the task manager that the CPU is used mostlyCPU and GPU usage and even though it is set on multiple tiles it is still using only one. How could I increase the GPU usage and the amount of tiles? Thank you for the answers:)

$\endgroup$
  • 1
    $\begingroup$ You only have one GPU, so blender will only render one tile at the time. Rendering on GPU doesn't mean that the CPU is not used at all. You can try some of the experimental builds that allow you to render using GPU and CPU simultaneously. $\endgroup$ – cegaton Jun 8 '18 at 4:53
1
$\begingroup$

Switch on GPU compute in the task manager. That will show you something else ;-) GPU compute is different than realtime rendering to task manager. It shows 97% to me while GPU 3D is barely working.

Go to GPU click on one of the sub diagrams like copy and select compute_0 or 1 or whatever yours is called.

be aware that you need something like 1080 before it is faster than a modern day cpu with 4-8 cores.

$\endgroup$
0
$\begingroup$

As your main goal behind this question is to get faster renders, then it is worth checking your tile size setting --- this can make a big difference.

CPU's generally like smaller tile sizes (e.g. 32 or 64) and GPU's large ones (e.g. 256 or 512).

You may wish to try the Add-on "Render: Auto Tile Size", which you can enable from

File > User Preferences > Add-ons

$\endgroup$
  • $\begingroup$ I am trying to make it faster but the gpu is not being used almost at all. so I don't know if I should use the setting for the cpu or the gpu when it comes to tie sizes $\endgroup$ – andraskrajko Jun 10 '18 at 11:52
  • $\begingroup$ The best way is to do some test comparisons. Make or use an existing model for a test render and try different settings. I also had very low GPU usage at first (1 to 2%). 2 things made a big difference: $\endgroup$ – Fibon3 Jun 11 '18 at 7:17
  • $\begingroup$ 1) set the tile size big -- 256 or 512, and set Blender for GPU usage. $\endgroup$ – Fibon3 Jun 11 '18 at 7:18
  • $\begingroup$ 2) in the PC settings, set the performance. This may default to 'balanced' to (say on a laptop) give a balance between speed and power usage. Set it to top performance. $\endgroup$ – Fibon3 Jun 11 '18 at 7:19
0
$\begingroup$

Also, your CPU might still be faster if your GPU is not that high end. On my system, my 8-threaded CPU outperforms my GPU with CUDA, probably because it's an older model and a laptop. My video card is a combined Intel/Nvidia (bumblebee)

Unless, I just didn't use the right settings... But I noticed 8 tiles at the same time rendering through the CPU and only one with my GPU

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.