1
$\begingroup$

I have an IK armature set up to move a very simple arm around, but after pairing the mesh to the armature using Ctrl+P then selecting automatic weights it seems as though nothing happens. I select the lower_arm and go into weight painting and nothing is there. I'm not sure if its a problem with the mesh I made since I made it myself from a sphere then sculpted it, or if its something else. The file is attached for reference.

$\endgroup$
1
$\begingroup$

Before assigning a mesh to an armature, the deforming bones have to be marked as deforming by checking deform. When creating bones, this checkbox is enabled by default, you must have unchecked it at some point.

enter image description here

After that, select the mesh, then ⇧ ShiftRMB RMB select the Armature and Parent them ⎈ CtrlP e.g. with Automatic Weights. Note, how vertex groups are created for the bones, which have Deform checked.

enter image description here

To ensure deformation, the Deform must stay checked and the Armature modifier (created by the parenting earlier) must be visible.

enter image description here

$\endgroup$
  • $\begingroup$ Thank you so much! I was following a tutorial and they had unchecked deform, but I forgot to recheck it. Hindsight is 20/20 I suppose! $\endgroup$ – Michael O Jun 4 '18 at 18:23
  • $\begingroup$ @MichaelO Great on solving the problem. If this answer helped you, you can mark it as accepted by checking the arrow on its left. $\endgroup$ – Leander Jun 4 '18 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.