0
$\begingroup$

I created a 3D model in Blender and animated it with an armature and bones before exporting it to Unity3D. As some of the rotation animations arbitrarily made the mesh shrink, I had to select the “Preserve Volume” option in the armature modifier.

However, I realized afterwards that Unity3D doesn’t recognize Blender’s “Preserve Volume” feature. While the model’s animations played fine in Blender, the shrinkage problem resurfaced in Unity3D.

Any ideas?

$\endgroup$
2
$\begingroup$

From Cygon4's post (Feb 16, 2016)

[...] the "Preserve Volume" option (= dual quaternion skinning) does not exist in Unity.

You have to find a weights only method to preserve your volume. A common practice is to use a helper bone at angled areas.

  1. Create the chain of bone1 and bone2.
  2. Create bone1_helper and parent it to bone1.
  3. Constrain the rotation from bone2 to bone1_helper, use local space and an influence of 0.5.

enter image description here
The gif showcases the base model, then Preserve Volume option, then the helper bone option.

Bake the animations with visual transform before exporting.

$\endgroup$
  • $\begingroup$ Thank you so much Leander, I really couldn't ask for a more detailed and helpful answer. Looking forward to try this method tomorrow. $\endgroup$ – Omri Jun 4 '18 at 22:55
  • $\begingroup$ Hi. Unfortunately this still isn't working for me. The mesh deforms badly and loses volume, no matter what I try. $\endgroup$ – Omri Jun 5 '18 at 11:52
  • $\begingroup$ @Omri Can you elaborate on that? no matter what I tried what did you try? And could you reproduce this behaviour? What does deforms badly mean? You can also edit your question to bump it and add additional more specific information. $\endgroup$ – Leander Jun 5 '18 at 11:54
  • $\begingroup$ I tried playing around with the weight and settings of the helper bone and the rest of the bones but couldn't get this to work. deforms badly means it loses volume when bones rotate. I've been searching and googling it for two days now and it seems there is no good solution for my problem, while your solution seems to be the best, I still can't get it working properly. I did read something about corrective shapekeys that might be my savior(?). I think ill just give you the blend file with the associated part so you can look for yourself. $\endgroup$ – Omri Jun 5 '18 at 12:01
  • $\begingroup$ @Omri If you can afford to use corrective shapes, use them (!) they are much better suited for your problem. There are plenty of tutorials on the web. $\endgroup$ – Leander Jun 5 '18 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.