0
$\begingroup$

Orbiting around objects with the MMB MMB, or ⎇ AltLMB LMB is working, and zooming is working with ⇧ Shift+/-,

However panning using ⇧ ShiftLMB LMB or ⎇ AltLMB LMB, and ⇧ ShiftMMB MMB are not functioning anymore. Neither is zooming in/out with scroll wheel. I've reset to factory defaults and restarted Blender several times.

My system:

macOS Sierra
Version 10.12.4

MacBook Pro (Retina, Mid 2012)
Processor 2.3 GHz Intel Core i7 Memory 16 GB 1600 MHz DDR3
Startup Disk Macintosh HD
Graphics

  • NVIDIA GeForce GT 650M 1024 MB
  • Intel HD Grphics 4000 1536 MB

Serial Number C02J71T5DKQ4

My storage and files are being accessed from an external drive.

$\endgroup$
  • $\begingroup$ thanks Leander for edit...have restarted my system and tried a new mouse with exact same problem still occuring. $\endgroup$ – jitterbug Jun 4 '18 at 23:31
  • $\begingroup$ the edited content in my original post should read "however using SHIFT + ALT + LMB does not work for panning... (I think its been interpreted as shift LMB or opt/alt LMB). $\endgroup$ – jitterbug Jun 5 '18 at 9:42
  • $\begingroup$ Why would you even include the serial number of your MacBook, but leave out which version of Blender you're using? $\endgroup$ – dr. Sybren Nov 14 '18 at 11:34
  • $\begingroup$ Just a side note, but I had the same problem. For me it was a tablet update that changed my button allocations. $\endgroup$ – Kanga May 9 at 6:57
-1
$\begingroup$

after restarting Blender many times over 2 days, and loading factory settings, finally decided to try changing orbit turntable to trackball instead, everything worked normally again once I did that. Changed back to turntable and saved to test it, things still working normally. problem solved.(so far). i`ll update this if status changes again.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.