1
$\begingroup$

So I am taking a short course modeling house on Udemi. I noticed that when I use extrude command it is very easy to snap to another vert. However, at one point we need to subdivide (basically one vert missing) to help with making a wall. The teacher just grabs this vert, constrains it to x and snaps it in-line with another vert. My blender will not do that, even if I have the same snapping settings on as the teacher's Blender. Blender seems not to notice the vert I want to snap to while grabbing, but if I extrude from another place it snaps to it with no problem.
Then I tried to move a door opening to have it in-line with another door, but it will not snap. If I extrude from a vert, it snaps where I want it to snap within second. My settings are: Snap on, vertices, closest, and snap onto itself. Am I missing some settings or is this a bug? enter image description here

$\endgroup$
  • $\begingroup$ Can you post the blender file you are having trouble with so we can have a look at it? blend-exchange.giantcowfilms.com $\endgroup$ – Prime_Aqasix Jun 1 '18 at 3:58
  • $\begingroup$ The site you asked me to upload to doesn't allow me to update my file. I drag my file to the box, check the "accept terms and conditions" give my link and press upload just to have an error saying "Please accept terms and conditions". $\endgroup$ – Ólafur Víðir Guðbjargarson Jun 1 '18 at 20:54
  • $\begingroup$ I have tried several times now, always get the same error. IF I accidentally uploaded the same file multiple times, I am sorry. The site here asks me to accept terms and conditions. I don't know where else I should accept but the box below the drag-n-drop box. $\endgroup$ – Ólafur Víðir Guðbjargarson Jun 1 '18 at 20:58
  • $\begingroup$ Just upload it somewhere, google drive is a good choice, I just linked that site because it is the most common site for blend files here. $\endgroup$ – Prime_Aqasix Jun 2 '18 at 0:59
  • $\begingroup$ I managed to add the file yesterday. Then I got a "Suggested edit" which I have no idea how to use. $\endgroup$ – Ólafur Víðir Guðbjargarson Jun 2 '18 at 22:39
1
$\begingroup$

The problem is that you have proportional editing on, press O, or the blue dot at the bottom of the viewport to turn it off (see circled in red) screenshot You also might have forgotten to turn auto merge on (circled in blue), as you seem to have 4 vertices overlapping. To remove them, select everything (A) and use the Remove Doubles function (Press space and search up Remove Doubles).

$\endgroup$
  • $\begingroup$ This was too simple, thank you anyway for the time. I feel bit silly for this post now :/ $\endgroup$ – Ólafur Víðir Guðbjargarson Jun 4 '18 at 8:26
  • $\begingroup$ @ÓlafurVíðirGuðbjargarson Please accept it as the correct answer by clicking on the tick :) $\endgroup$ – Prime_Aqasix Jun 4 '18 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.