I have plane with 200x100 loopcuts, when I export glb the size of the file is around 2MB than I again sub divided the mesh couple of times and now binary file is around 8MB.

How can I use more number of loop-cuts and still maintain the file size smaller?

I am using latest version of glTF exporter and blender.


1 Answer 1


If your goal is a smooth appearance, you can use smooth normals to give the effect of a smooth surface with fewer loopcuts. If you are sure you need the loopcuts, your options are:

  • Disable export of normals, tangents, UVs, and any other per-vertex data you aren't using in the exporter settings.
  • The glTF format supports compression, but you'll have to apply it to the model after exporting from Blender. Use glTF-Pipeline to compress the model with the -d flag and you should see a file size reduction of 90-95% for models that contain primarily geometry.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .