25
$\begingroup$

How to render perfect cartoons in blender? Whatever the engine is (internal or cycles) I always get that shading transition somewhere on the model.

Blender internal render engine

Cycles render engine

The first picture is in blender internal render engine with the toon shading material and the second picture is in cycles render engine with the toon shader.


How can I get completely flat colors with no fancy shading variation?

shading transition

no shading transition

$\endgroup$
4
  • $\begingroup$ have you tried to add another lamp (Hemi) to your scene I don't get these pronounced shadows? $\endgroup$
    – stacker
    Jun 2, 2014 at 21:36
  • $\begingroup$ to stacker - I lowered the light bounces in cycles - min-1, max-2 $\endgroup$
    – Vladimir
    Jun 2, 2014 at 22:27
  • $\begingroup$ I tried Light BWK's explanation, but I still get the same results. Basically, I want to make a cartoon animation in cycles with completely flat colors. $\endgroup$
    – Vladimir
    Jun 3, 2014 at 15:42
  • $\begingroup$ Well.. okay. I thought your original example image kind of implied that this was part of your other question, but if it's not, then I guess this works as a separate question. $\endgroup$
    – gandalf3
    Jun 3, 2014 at 19:12

8 Answers 8

15
$\begingroup$

Another way in Cycles would be to create a shader on the compositor that affects the overall rendering, or just the materials you want.

In this example the monkey on the right has a material with an index pass of 1. In the compositor I'm using a color ramp to remap the shading. The two tone shading is achieved using constant as interpolation on the ramp.

enter image description here

The rest of the materials are unaffected by the ramp.

$\endgroup$
6
  • $\begingroup$ I really like that one, but the render time would be expansive. $\endgroup$
    – Vladimir
    Jun 3, 2014 at 11:21
  • 1
    $\begingroup$ not by a lot... $\endgroup$
    – user1853
    Jun 3, 2014 at 14:25
  • 1
    $\begingroup$ Why am I sent to this page when I want an entire scene to be cell shaded? Yet every example is just changing 1 material to ramp. That's not what I want. $\endgroup$ Nov 18, 2016 at 7:27
  • $\begingroup$ @EricHuelin When commenting, at least add a link of the question/comment that is sending you here. $\endgroup$
    – user1853
    Nov 18, 2016 at 14:45
  • $\begingroup$ blender.stackexchange.com/questions/67323/… $\endgroup$ Nov 19, 2016 at 3:44
20
$\begingroup$

base Toon/cell shading

These are the settings you need to change to set flat toon/cel shading. To get rid of aliasing with constant interpolation, in options panel, turn on Full Oversampling. There are limitations, noted them in the graphic.

$\endgroup$
12
$\begingroup$

In BI this can be done by using toon shading and setting the smooth value to 0, then feeding it into a color ramp:

enter image description here

I also disabled specular highlights by setting the specular intensity to 0.

$\endgroup$
10
$\begingroup$

You can do something similar to cegaton's solution in Cycles by feeding the same type of ramp he used through the color input of a toon bsdf shader.

enter image description here

enter image description here

EDIT: This is a solution you do in the material, not the compositor.

$\endgroup$
2
  • $\begingroup$ This isn't even Freestyle! It's just the material node editor. (But you can definitely add that on top of this for better lines.) Freestyle is applied after everything is rendered, then added. I'm not sure if Freestyle is done before compositing, or not. $\endgroup$ Nov 6, 2015 at 14:38
  • $\begingroup$ Thanks for the tip ;). I meant to type "cell shading". I often mistype it 'cause they often go hand at hand in cartoons. Yeah, it is a compositing effect $\endgroup$
    – Vladimir
    Nov 6, 2015 at 20:42
7
$\begingroup$

After some trial and error I created my BI toon shading setup in Cycles. This is a very simple and useful setup. You can easily decide light and shadow direction with lamp in scene and object shading with ColorRamp node. If you use this setup with Freestyle it can be nice looking cell shaded objects. And if you don't want to change shadow position while animating objects (which is I recommend it) parent your lamp the object.

Here is the my setup. enter image description here

$\endgroup$
1
  • $\begingroup$ I like this. Your node setup didn't work for me because in the Texture Coordinates node I was using a real lamp. When I changed it to some non-lamp object (e.g., a sphere) then it worked. $\endgroup$
    – lumpynose
    Nov 15, 2017 at 0:01
4
$\begingroup$

I use the internal blender engine for cartoon style render all the time. if you don't want shadows on it in the material tab down in the shading section check the button beside shadeless and it takes away the shading and shadowing. also if you want a outline like a line drawing outline in the render tab check edge and adjust to the way you like it.

$\endgroup$
1
$\begingroup$

I use this setup for EEVEE only.

enter image description here

When rendering turn on Freestyle to get outlines.

enter image description here

$\endgroup$
0
$\begingroup$

You can Experiment with Ambient Occlusion and External lighting under the World Settings Panel for more toon like effects AND the Stroke & Freestyle (1 px is more than enough) settings under the Render Section for edge strokes and outlines on objects.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.