2
$\begingroup$

I am trying to make a room in blender, I finished making the beds that I now want to render so I can see how it looks when its rendered fully...except I can't seem to render it, I just finish my scene, set the samples number and resolution, and press render, it loads I what it need for it to render, but when it arrives at the point where its "updating Meshes" blender crashes without even an error, I sure its not a RAM issue since it didn't fill up the RAM in task manager.

Here are my 2 laptops specs (I tried the second one to see if there was a RAM issue):

First one (my main one)

Windows 10 1803 32-bit

2gb RAM

Intel Core 2 Duo T5870 @2Ghz

Intel Mobile Chipset Express Series integrated graphics card

Second one

Windows 7 32-bit

Intel Core 2 Duo @2.4Ghz

3gb RAM

Nvidia card (forgot which one) (512 VRAM)

Im dealing with: enter image description here

I have 4k textures, its a 1920*1080 image, tile size is 128*128, samples 200

P.S: I still use 2.76 since my computers can't support opengl 2.1

Here is the file if anyone wants to diagnose it: (removed it since problem is solved)

$\endgroup$
  • 2
    $\begingroup$ It is quite likely that the scene's complexity is larger than the computer resources. 2 or 3GB is very little RAM. Most of that is used by the operating system itself. How many vertices/faces are you dealing with? What size image are you rendering? How large are the textures you are using? What kind of modifiers are you using? Please use the edit link at the bottom of your question (i.stack.imgur.com/lXFuK.png) and add more information. Add images that show the geometry render serttings and modifiers you are using. $\endgroup$ – cegaton May 23 '18 at 15:57
  • $\begingroup$ As I suppose you render on CPU on that configuration tile size should be smaller, like around 64. 4K textures can be one of the reasons for crash since they need quite big amount of RAM, try using at least 2K. RAM usage can be relatively small because Blender isn't fitting there anyway so it crashes before even starting moving data to memory (often it would bring you a message but might be not). If really rendering exactly that scene on that hardware split it into render layers $\endgroup$ – Mr Zak May 23 '18 at 18:31
  • $\begingroup$ I'll try reducing the texture size and tile sizes and I'll give you feedback in 12 hours at least @MrZak $\endgroup$ – watass May 23 '18 at 18:35
  • $\begingroup$ 4K textures is probably beyond what your computer can deal with. Also, is hard to help you if you do not share the requested information... $\endgroup$ – cegaton May 23 '18 at 20:58
  • $\begingroup$ I tried reducing the texture size to 2k and tile size to 64*64 AND reducing the resolution from 1920*1080 to 720*480 and it kept crashing, maybe there is something wrong with the scene that makes it crash? $\endgroup$ – watass May 24 '18 at 16:27
1
$\begingroup$

I agree with what cegaton said. I've got similar specs as you, and wasn't about to wait and hour & a half for it to render, so these were the settings I changed.

It rendered all 3 layers in about 20 mins, but they didn't merge into one final image, so you'd have to add some sort of compositing step in there somewhere, or just move the beds to the same render pass as the headboard.

I'm on 2.79b so your settings may vary.

output
light
denoise
simplify

$\endgroup$
  • 4
    $\begingroup$ Note that denoising will also icrease memory usage. Why does Denoising take up so much memory? $\endgroup$ – cegaton May 24 '18 at 18:02
  • $\begingroup$ guess that makes sense. with everything else reduced it did OK, plus it's quicker 'cuz you can turn samples down some. $\endgroup$ – Doyousketch2 May 24 '18 at 19:13
  • $\begingroup$ Your method worked! But the branch path tracing step was uneccesary and since I wanted to render it in 1080p 64*64 tile sizes is better $\endgroup$ – watass May 25 '18 at 8:09
1
$\begingroup$

Similar questions are asked regularly in this site, and the answer is mostly the same: the scene's complexity is larger than the resources available on your computer.

Some of the reasons your scene demands so much RAM:

  • You are using a lot of very large image textures (2x and 3k). Even though you are using jpg compressed images that might not seem like large files, blender needs to access the image as a whole decompressed image. The larger the image, the more RAM used.

    Read: Why does Blender use so much memory for large textures?

  • Some of the subsurf modifiers have a subdivision level of 5 for rendering. For every level of subdivision you are increasing the number of vertices exponentially, so it is easy to run into a situation where you have a very large number of vertices.

    Try to keep the subsurf levels as low as you can by using better topology and using fine detail only in those areas that need a lot of detail.

    For more info read: Blender render crash when using subsurf modifiers.

  • You have 3 different render layers that you want to render simultaneously. Blender has to cache the information of every layer separately and keep it available for compositing.

    A workaround is to render each of the layers separately, save it as an EXR file and combine them later in the compositor or other compositing app.

    Read also: How to Render a Complex Scene without it Crashing


As is, your scene needs at least 1gb of ram to render:

enter image description here

2 or 3GB is very little RAM. Most of that is used by the operating system itself, leaving you very little to work with. Microsoft's requirements to run WIndows 10 are: 1 gigabyte (GB) (for the 32-bit version) or 2 GB ( for the 64-bit version)

To deal with scenes that are larger than your available computing power consider using a render farm or try to get access to more powerful computers.

A (slow) alternative is to try to change the settings of your operating system to use more virtual memory. But that you will have to research yourself as it is out of the scope of this site.

$\endgroup$
  • $\begingroup$ Thank you for the explanation, except I can't send it to a render farm now, and I am consider buying a new computer or upgrade the ram for the one I am using currently $\endgroup$ – watass May 25 '18 at 8:11
1
$\begingroup$

I'm replying to help others searching, as this question came up in my search for a similar problem.

I have a scene with fur, it's pretty detailed and heavy on the rendering. The scene would work fine on my desktop but blender would disappear (kill itself) somewhere during 'raytree... building' on the laptop. It wasn't completely filling the ram, there was still half a gig left when it would disappear.

Both systems have 16gb ram, desktop and laptop and I had disabled the windows swap/pagefile under virtual memory on the laptop at some point. Once I enabled it again and rebooted, everything works again now.

Just google 'disable pagefile' to find out where the dialog is hidden so you can make sure your pagefile is enabled. (or maybe search 'enable pagefile')

(My pagefile was disabled because somewhere I read if you have lots of ram you don't need to swap to disk and you save that much ram in disk space. For most programs it was true, but blender can easily consume the 16gb ram I have with a detailed scene. Hopefully it might save someone else who is searching around 30mins or more and some hair pulling.)

$\endgroup$
0
$\begingroup$

Just an FYI, I was having a really bad problem with crashing during render, in a not very complex scene. Playing with different settings eventually led me to turn off auto detect on threads and set it below the max number of cores on my CPU. Instantly solved that issue, and at least seat of the pants had 0 affect on render time.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.