1
$\begingroup$

I'm trying to export a bone animation. I've followed a lot of the suggestions found in this helpful tutorial, with success. Near the top, they suggest that I avoid unchecking the 'Inherit Rotation' box on any bones, as it will not export properly. They also suggest the following vague workaround:

There's a tricky workaround for this, which is creating a helper bone which the bone that you don't want to rotate will copy its rotation.

Can someone explain this workaround in more detail for me? If you're familiar with the armature created by the Rigify add-on, I'd like the bone called 'spine' to not rotate with the bone called 'hips', but I would still like 'spine' to follow 'hip's position. How can I achieve this without unchecking Inherit Rotation?

Update: I've included the .blend file here. The bone that has 'inherit rotation' unchecked is the 'spine' bone. I'd like to be able to use the workaround on that bone. When I load this model into Assimp, his whole upper body rocks right and left (as if the spine bone was inheriting the rotation of the hips bone).

$\endgroup$
0
+50
$\begingroup$

I can't tell you how to solve your problem but I think I can tell you about the helper bone.

Long time ago I implemented a bvh importer for another software (not blender), to get it working with the rotations given in the bvh file I had to add an helper bone for each existing bone.

A zero length bone (no influence to the mesh) placed at the origin of the original bone, and obviously the original bone must be parented with the helper (original child, helper parent), all the rotations are applied to the helper only.

| improve this answer | |
$\endgroup$
0
$\begingroup$

I looked at your file, there was a warning triangle in Motion Paths, need to re-calculate or re-calibrate the motion paths to make it walk more smoother.

I think the idea is that you have to re-do it when you change positions of the bones or if you add in something new.

| improve this answer | |
$\endgroup$
  • $\begingroup$ The Active data frame that looks like a frame of the bones. There was a triangle in Motion Paths Around Frame or In Range. I re calculated the motion mesh and it walks more normal after update of paths . I am using blender version 2.71 $\endgroup$ – user294626 Jun 20 '14 at 8:41
  • $\begingroup$ I don't understand. Does the warning with motion paths have to do with the inherit rotation workaround? If not, this should have been a comment on my question, not an answer. $\endgroup$ – Justin Jun 20 '14 at 12:36
  • $\begingroup$ img705.imageshack.us/img705/176/arma.gif $\endgroup$ – user294626 Jun 21 '14 at 7:20
  • $\begingroup$ Add in a help bone or move your rig so no over lap occur. Some times help bone will help. When exporting, make sure you have mesh or rig of actions in 0 state topology before exporting. Yes , do not uncheck the inherit of rotation since you wanna keep your rotations, bends etc instead of inheriting them from the location where you are going to use your baked animation file. Parent inherits should be from the blender when exporting. wildfiregames.com/forum/index.php?showtopic=17842&p=278688 $\endgroup$ – user294626 Jun 21 '14 at 7:26
  • $\begingroup$ When you re-calculate or re-calibrate your motion mesh it will make your baked animation own 0 state toplogy before exporting it out.So when you open it in a new location your mesh does exactly the same as in blender when you test run it. $\endgroup$ – user294626 Jun 21 '14 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.