I try to render a Video with Blender's video editor. Under Output I set FFmpeg video as file format. Under Render I set Container to MPEG-4, Video Codec to H.264 and Audio Codec to AAC (with a bit rate of 320) as I was used to in other programs. Then when I try to render my video, Blender gives an error "Unsupported channel layout". I did an internet search for the error bud could not find anything related to my issue.

This is the channel layout of my project. enter image description here

I tried deleting strip after strip from the channels to find the offending one but it didn't render even with nothing in it. I guess that with channel layout is something else is actually meant.

I use Blender (Version 2.79) on ArchLinux (Manjaro), as far as I can tell, all the needed packages are installed. Playing other videos with AAC-Encoding in a Player works fine. The only encoding I could get to work with MPEG-4, was Vorbis but then the sound seems to be missing when the video is played in a browser for some reason, also some players seem to think the video has no audio (plays perfectly with sound in VLC).

I really would like to render to MP4 with AAC because that's what most websites want in order to have them playable.

Edit: So far I was able to pin it down to being a problem with FFMPEG. I started Blender with --debug-ffmpeg and got this:

Starting output to /run/media/takiro/Videos/nyaaa_and_spyro

/out/0001-13241.mp4(ffmpeg)...
  Using type=2, codec=27, audio_codec=86018,
  video_bitrate=6000, audio_bitrate=320,
  gop_size=18, autosplit=0
  render width=1920, render height=1080
Using global header
ffmpeg_property_add: video coder:vlc
ffmpeg_property_add: video cmp:chroma
ffmpeg_property_add: video partitions
ffmpeg_property_add: video partitions
ffmpeg_property_add: video partitions
Ignoring unknown expert option me:hex
ffmpeg_property_add: video subq
ffmpeg_property_add: video me_range
ffmpeg_property_add: video qdiff
ffmpeg_property_add: video keyint_min
ffmpeg_property_add: video sc_threshold
ffmpeg_property_add: video i_qfactor
ffmpeg_property_add: video b_strategy
ffmpeg_property_add: video bf
ffmpeg_property_add: video refs
ffmpeg_property_add: video qcomp
ffmpeg_property_add: video trellis
ffmpeg_property_add: video weightb
ffmpeg_property_add: video 8x8dct
ffmpeg_property_add: video fast-pskip
ffmpeg_property_add: video wpredp
FFMPEG expert option: coder:vlc: 1.
FFMPEG expert option: cmp:chroma: 1.
FFMPEG expert option: partitions: partb8x8.
FFMPEG expert option: subq: 6.
FFMPEG expert option: me_range: 16.
FFMPEG expert option: qdiff: 4.
FFMPEG expert option: keyint_min: 25.
FFMPEG expert option: sc_threshold: 40.
FFMPEG expert option: i_qfactor: 0.71.
FFMPEG expert option: b_strategy: 1.
FFMPEG expert option: bf: 3.
FFMPEG expert option: refs: 2.
FFMPEG expert option: qcomp: 0.6.
FFMPEG expert option: trellis: 0.
FFMPEG expert option: wpredp: 2.
[libx264 @ 0x7f1a87c0f900] using SAR=1/1
[libx264 @ 0x7f1a87c0f900] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
[libx264 @ 0x7f1a87c0f900] profile High, level 4.0
[libx264 @ 0x7f1a87c0f900] 264 - core 152 r2854 e9a5903 - H.264/MPEG-4 AVC codec - Copyleft 2003-2017 - http://www.videolan.org/x264.html - options: cabac=0 ref=2 deblock=1:0:0 analyse=0x3:0x100 me=dia subme=6 psy=1 psy_rd=1.00:0.00 mixed_ref=0 me_range=16 chroma_me=1 trellis=0 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=1 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=0 b_bias=0 direct=1 weightb=1 open_gop=1 weightp=2 keyint=18 keyint_min=10 scenecut=0 intra_refresh=0 rc=crf mbtree=0 crf=23.0 qcomp=0.60 qpmin=10 qpmax=51 qpstep=4 ip_ratio=1.41 pb_ratio=1.25 aq=1:1.00
alloc video stream 0x7f1a87c2e000
ffmpeg_property_add: video coder:vlc
ffmpeg_property_add: video cmp:chroma
ffmpeg_property_add: video partitions
ffmpeg_property_add: video partitions
ffmpeg_property_add: video partitions
Ignoring unknown expert option me:hex
ffmpeg_property_add: video subq
ffmpeg_property_add: video me_range
ffmpeg_property_add: video qdiff
ffmpeg_property_add: video keyint_min
ffmpeg_property_add: video sc_threshold
ffmpeg_property_add: video i_qfactor
ffmpeg_property_add: video b_strategy
ffmpeg_property_add: video bf
ffmpeg_property_add: video refs
ffmpeg_property_add: video qcomp
ffmpeg_property_add: video trellis
ffmpeg_property_add: video weightb
ffmpeg_property_add: video 8x8dct
ffmpeg_property_add: video fast-pskip
ffmpeg_property_add: video wpredp
[aac @ 0x7f1a87c0ef00] Unsupported channel layout
Closing ffmpeg...

I'm not sure what I should read from this. From the new information I assume with channel layout the channels of the audio files are meant but I did not find a way to configure that in blender. In my user settings, channel is set to stereo. My FFMPEG is version 4.0

As a workaround I render without audio, then export the audio and use ffmpeg from the command line manually to mux both files. No problem with ffmpeg and AAC in this case but the extra step is kind of an annoyance.

  • Yes, I also get the same error using the latest Blender Master. Did you try to use 2.79b? – aditia Aug 29 at 7:44

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.