2
$\begingroup$

I've a problem with the rigid body animation of 2 created gears. The gears always end up overlapping each other.

enter image description here

Edit:

The gears in the first file have a module of 1.5. When the sensitivity of the gears is set to 0.01 the animation works.

The gears in the second file have a module of 0.5. In the second blend file the animation still breaks even with a sensitivity of 0.01. Are the gears in the second blend file to small to animate with rigid body?

Second blend file

$\endgroup$
  • $\begingroup$ Welcome to Blender SE. Looks like you could get smoother action if you increased the sensitivity margin. Try 0.1 on both cogs. $\endgroup$ – OroNZ May 18 '18 at 10:37
  • $\begingroup$ @OroNZ, thank you this seems to solve my problem. A sensitivity of 0.1 works fine. 0.01 also works but 0.001 will brake the animation again. $\endgroup$ – sfh May 18 '18 at 10:50
1
$\begingroup$

To improve the accuracy of the Rigid Body simulation you can increase the Steps setting in the Rigid Body World settings of the Scene properties. This defaults to 60 - larger values breaks the simulation into smaller steps at the expense of taking longer to calculate - try increasing by a factor of 10 or more. Smaller steps results in better collision and a more stable simulation.

However, that isn't actually the problem with your animation. The problem is actually due to the meshes themselves - the normals are flipped and pointing 'into' the object rather than 'out'. This means that the collision becomes confused and Blender is behaving as if the objects are actually caught within each other which results in the 'stuck' animation as one cog attempts to turn.

The solution is to simply select each cog in turn, enter Edit mode (Tab), select all (A until all is selected) and press Ctrl+N to Make Normals Consistent. This tells Blender to recalculate the normals, by default pointing them 'out' of the object.

Once the normals were corrected I didn't need to make any other changes on your file for the cogs to animate.

$\endgroup$
  • $\begingroup$ With the first file this seems to have little imapct. The animation in first file works if I change the value of the sensitivity to 0.1 or 0.01. For the second file this solutions doesn't work. I tried setting the solver iterations to 100, 200, 500 and 1000 for the second file. $\endgroup$ – sfh May 18 '18 at 14:23
  • $\begingroup$ Sorry - my bad - I was actually intending to describe the Steps setting, not the iterations. However, I think I've spotted the problem and it isn't actually related to the Rigid Body settings.... I'll update my answer. $\endgroup$ – Rich Sedman May 18 '18 at 16:03
  • $\begingroup$ thank you. Once the normals are fixed the animation runs fine. $\endgroup$ – sfh May 19 '18 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.