Windows updated a few days ago

Version 10.0.17134 Build 17134

I noticed the Windows app "create password reset disc" opens, with no window. I can see it in alt-tab, but when selecting it, nothing shows up.

Today I ran BLENDER, and only the window frame with title plus minimize, maximize, and close icons appears. No contents appears in the window.

I did not see this in any other applications. I explicitly tried other graphical applications: - Inkscape - Gimp - CURA (3D slicer)

I tried opening blender "as administrator" - did not help.

Thanks for any help

  • 1
    $\begingroup$ Win 10 tends to think it's smart enoough to not ask you anything when updating. As it stands OS likely upgraded graphic drivers (OpenGL in particular) and now Blender isn't compatible with them. Try rolling them back. $\endgroup$ – Mr Zak May 17 '18 at 20:00
  • $\begingroup$ Thanks for the quick response. I'm going to have to dig for the open GL driver to see if I can do something about it, vs trying to roll back last week's Windows 10 update. $\endgroup$ – Ward Christensen May 18 '18 at 1:49
  • $\begingroup$ I opened an air-gapped (no networking) Windows 10 box today and installed blender, it works fine. I'm going to have to use USB keys to move models to/from blender. I might also install it on a Windows 8 box which hopefully won't update to an unworkable situation. $\endgroup$ – Ward Christensen May 28 '18 at 22:15
  • $\begingroup$ FYI, I upgraded to 2.79b, no help. $\endgroup$ – Ward Christensen May 28 '18 at 22:21
  • 1
    $\begingroup$ Today I found that Google Earth Pro didn't work, and searched and found a fix to switch it from OpenGL to DirectX. That WORKED. So it probably is OpenGL that's killing my Blender. With no DirectX alternative, I'm abandoning Blender on this machine. I'm keeping an air-gapped (no networking) ThinkPad with Windows 10 and Blender, for emergencies, while putting my 3D efforts for my 3D printer into things like OpenSCAD. Sigh. Thanks for your help. Newer drivers won't help, probably because Blender started using newer OpenGL facilities that I can't support on this machine. $\endgroup$ – Ward Christensen Jun 20 '18 at 2:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.