0
$\begingroup$

I'm experimenting with Animation Nodes to create a set of Bezier curves that start near one empty (SPole, left arrow), pass near a second empty (Midpoint, cross at top), and end near a third empty (NPole, right arrow). The first step in my experiment is to create a single Curve object and then extend the Node tree to generate the rest of the set of Curves. Here is a 3D view and the Node tree I've constructed so far:

enter image description here

To be clear, the two reroute nodes in the tree on the right are simply there to make the tree more compact for the screen capture.

Not shown in the Curve settings: the preview resolution of the curve is 12 and the render resolution of the curve is zero. These values seem to be fixed by AN as I cannot change them. When I add a shader and test render this curve, it has a resolution of 12. It is clearly a resolution of 12 in the 3D view shown, too.

How can I increase the resolution of the generated curve? I've looked through practically every Animation Node in version 2.0 and can't find a "Set Curve Resolution" node. Several YouTube videos on generating curves with AN also have low curve resolutions visible in their finished Curve object(s). I also tried to set the Resolution Attribute directly, but I didn't have any success.

Thanks in advance!

$\endgroup$
4
$\begingroup$

you can change the visibility of some inputs in the properties shelf (press N in the Node Editor).

select the curve object output node and check the eye icon for preview resolution. you can now set the resolution in the node itself

enter image description here

$\endgroup$
  • $\begingroup$ As a new AN user, I completely forgot Jaques hides sockets within the nodes. It would explain the lack of another node for the resolution. Since this answer gets to the root of my question, I'll mark it as the answer. But I've upvoted both bstnhnsl's and Jaroslav's posts because they both solve my problem. Thanks to both of you. $\endgroup$ – astrogeek May 17 '18 at 13:21
4
$\begingroup$

Change the Curve object attributes after the Curve Object Output node:

enter image description here

If you do this before the node, the attribute get's overwritten by the Curve Object Output default, which is 12. That's why it probably didn't work for you:

enter image description here

$\endgroup$
  • $\begingroup$ is there a drawback to just set it IN the curve object output I'm not aware of? $\endgroup$ – bstnhnsl May 17 '18 at 10:21
  • $\begingroup$ @bstnhnsl no, there is no drawback, only positives. You have less nodes so less clutter, and you are setting it all in one place only once and not twice (the curve output sets it to 12 even when the input is hidden..). Enabling the input is the more elegant solution when it can be done. When there is not the option to do so, you have to set the atribute with Attribute Output node, I just didn't check first if it can be enabled. $\endgroup$ – Jaroslav Jerryno Novotny May 17 '18 at 10:27
  • $\begingroup$ I tried creating the set of nodes shown in red as a separate tree without linking into the curve-generating tree. Nice illustrations. $\endgroup$ – astrogeek May 17 '18 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.