0
$\begingroup$

I am working on a school research project and hence I cannot share the blender file (confidentiality BS). I am getting strange lines in the render where there are stacked "glass" tiles. This occurs only in the final render and not in the preview render. I have tried the following but to no avail:

  1. Increasing spacing in between (the tiles are not touching each other)
  2. Increase light rays
  3. Smooth Shade Toggle and Edge Split Toggle
  4. Toggling Caustics
  5. Changed Material from Glass to Principled shader

Blender File: https://drive.google.com/open?id=1OERauRJs8S7BAYAZq7S64UlmmxdvrcSL

enter image description here

Final Render (500 samples)

Preview Render

Preview Render (32 samples)

enter image description here

Final Render (1000 Samples)

enter image description here

Preview Render (1000 samples)

Edge Split Modifier

Render Settings

$\endgroup$
  • $\begingroup$ Check your scene objects if some have rendering flag disabled. Check your modifiers if you have different values in Render / Preview. Does it render the same way if you use 32 samples in Render as you do in preview? $\endgroup$ – kheetor May 17 '18 at 11:43
  • 2
    $\begingroup$ I don't have an idea which lines do you mean and where to search for them. Either mark them on the images or crop images to adjacent area. Generally if there are black lines in the render of glass with multiple layers then Transparency bounces should be increased in Render tab > Light Paths panel $\endgroup$ – Mr Zak May 17 '18 at 11:43
  • $\begingroup$ Furthermore, I can't seem to see the difference between the first two images on first sight. Please add more information to make that clear. $\endgroup$ – Leander May 17 '18 at 11:45
  • $\begingroup$ @MrZak I increased it to 500. There was no change $\endgroup$ – Prasanna R N May 18 '18 at 1:12
  • $\begingroup$ @Leander I have marked the stuff that I am talking about $\endgroup$ – Prasanna R N May 18 '18 at 1:13
1
$\begingroup$

It looks like you have an object hidden in the viewport that is showing up in the render.

Look for a setting in the outliner similar to this and either hide that object in the render or delete it:

enter image description here

Alternatively, you can press Alt+H, and you should see all hidden objects in the viewport. Then you can select and delete/disable anything you need to.

This script will automatically hide all objects in the render that are hidden in the viewport:

import bpy

for obj in bpy.context.scene.objects:
    if obj.hide and not obj.hide_render:
        obj.hide_render = True

Putting this here for reference...

Why does my object not show up?

$\endgroup$
  • $\begingroup$ Why do you think that is the cause? I checked the entire object list. Everything is visible. $\endgroup$ – Prasanna R N May 18 '18 at 2:23
  • 2
    $\begingroup$ @PrasannaRN Perhaps you are not viewing the correct scene in the outliner? It certainly looks like artifacts caused by overlapping geometry on the floor and maybe some black object at the top. $\endgroup$ – JakeD May 18 '18 at 2:54
  • $\begingroup$ I don't think that is the issue. I have attached the blender file with just the floor tiles. Please have a look. It now looks likes those artefacts also appear in the preview render. Can they be the surface patches themselves? The tiles were made in Solidworks $\endgroup$ – Prasanna R N May 21 '18 at 4:37
0
$\begingroup$

My feeling is that even though you are using a principled BSDF shader, and not the regular glass shader, enter image description here

you might be facing the same issue as described here: How to illuminate the darkness inside glass objects in Cycles?, where cycles is not rendering caustics correctly.

Adding a light path node to control the mix with a transparent shader will allow for direct light to illuminate through the glass.

enter image description here

enter image description here

On top of that you might have other issues related to the clipping distance range for the camera being too large, which might reduce precision causing z fighting on surfaces that are close together... and then the topology of the objects might be adding other issues. I don't know. Maybe someone with more patience can address those in a different question.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.