0
$\begingroup$

so I have created this ak-47 mesh using blender enter image description here

and when I try to export it to UE4 it looks like this(I exported it as a .fbx file so I don't think this is the problem)e

As you can see for some reason the parts that are white in blender works fine but the parts that are grey are not.

when I crated this ak I first built it as a one object and then separated it to 4 different objects so I would be able to add different materials to each part later and I think this might be the problem somehow.

I'm new to blender and this is the first time I try to crate something without a tutorial so this might be a very stupid problem but I couldn't figure it out so thank you for the help :)

$\endgroup$
  • $\begingroup$ your normals seems inverted. Turn on backface culling in 3D view in blender and try CTRL+N $\endgroup$ – Sidar May 15 '18 at 21:30
  • $\begingroup$ Your mesh seems to have very poor topology $\endgroup$ – Duarte Farrajota Ramos May 15 '18 at 22:05
-1
$\begingroup$

I experienced this same problem. Open Blender and go into edit mode by clicking Tab. Then you need to select all the faces, and use Ctrl-N to recalculate the faces' normals. Finally click that thing that looks like a wrench and click solidify. By doing that you're making every face solid like a room and that should work.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.