I have captured some 1080p video game footage with Open Broadcaster. Now I would like to edit it using the Blender video editor. First of all, if I understand this correctly, I have to set the frame rate with which I want to render the video but I am not sure what to set it to, after all games don't run at constant frame rates.

Secondly I have tried dragging and dropping the clip I want to edit into the video sequence editor. Once I do that the video clip and the audio track that belongs to it show up, however they don't seem to be synced up and the video clip is far too short.

Maybe this information is of any use: the original video is 04:12 minutes long. The audio track displays as being of exactly that length in minutes and 30412 in frames. The video clip is displayed as being two seconds long with 254 frames.

I assume this has something to do with the end frame that can be specified but changing this to something higher has not solved the problem. Any suggestions are welcome!

  • $\begingroup$ Use in blender whatever the FPS is in VLC Media Information, not Codec Information as instructed above. $\endgroup$
    – user13434
    Mar 27, 2015 at 14:26
  • $\begingroup$ My instinct is that you will want a Speed Control effect strip modifying the source video. The Speed Control can be configured in a couple of modes, but the default Stretch To Input Length is likely what you want. $\endgroup$
    – Mutant Bob
    Mar 27, 2015 at 17:19

2 Answers 2


You need to find out what framerate your footage is at. A video is saved at a constant framerate no matter how fast the game runs. Find out what that is, and in the Properties Window on the Render Tab (the settings on the right which is usually hidden on the Video Editor interface), set the framerate.

Change frame rate

Then, in the Video Editor, drag your video in and find the end frame. Set the end frame to the ending frame of your video. (See this topic for help: How can I make my animation play for longer than 250 Frames? )

Also, set the player to A/V Sync (the button is right under the Timeline) so Blender will sync the audio and the video.

A/V Sync

  • $\begingroup$ First of all thanks for your answer! I looked up the frame rate in VLC under codec information and it was 120. I set the frame rate in blender to 120 and turned on AV-sync. However when I drag in the video clip it is still only 254 frames long. When I click around along the clip with the scrubber it seems the entirety of the video is there but it's just compressed into 254 frames. $\endgroup$ Jun 1, 2014 at 12:00
  • $\begingroup$ Could it perhaps have something to do with the fact that the video file is an mp4? VLC can play it without a problem but windows media player can't so maybe the codec is not installed and that's why blender has this issue? $\endgroup$ Jun 1, 2014 at 14:18
  • $\begingroup$ Blender uses FFMPEG for codecs like VLC does, so that should not be the problem. I am not sure why your video keeps doing that. How long (in seconds/minutes) is your video clip? $\endgroup$
    – rioforce
    Jun 1, 2014 at 18:46
  • $\begingroup$ ffmpeg can indeed be a problem. I described a workaround to use L-SMASH instead which gives much better results. $\endgroup$
    – Samoth
    Mar 21, 2016 at 19:52
  • $\begingroup$ sometimes the framerate of a video can be a very weird one like 26.5473, and when you want to set the project framerate to that Blender rounds it to the closest preset, which causes a desync. $\endgroup$
    – Tooniis
    Sep 22, 2017 at 3:49

Here was the best solution I came across.

He just dragged out the end of the video snip by grabbing it then dragging, he added speed effect by selecting the strip and then going to Add > Effects Strip.. > Speed Control, then he made sure the box that says "Stretch to input strip length" in checked in the Speed Controls.

By doing this he was able to change the rendering to match the audio file even within a project that had a different FPS


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .