0
$\begingroup$

Just had a quick question. In the image below, I am trying to get dust to show up at only the white parts of an image. I am trying to get a PBR dust effect where when you look at it, at an angle, you can see the dust film better. I know you do this with a fresnel node. The trouble that I am running into is that there is fresnel on the whole object and where white is on the object, that's where dust is supposed to be. I was able to access just the top parts of the model where dust should physically lie (second image below) but I can't figure out how to get the fresnel effect to work only on this top data.

The problem where I am getting fresnel everywhere: enter image description here

The top facing values where I only want the fresnel to work on (I want it to work on the white values): enter image description here

What're your guys' thoughts?

$\endgroup$
3
$\begingroup$

You are currently blending the fresnel and topside(normal) masks using a mixRGB node set to "mix". This gives you a blend of both masks. Sounds like what you're actually after is the area where both masks are non-zero, so the blending option you want is "multiply". You can either change the mode on the mixRGB node to "multiply", or replace it with a math node since these are float values (grey socket) rather than vectors/colors.

$\endgroup$
  • $\begingroup$ @JTtheNinja thanks the math node set to multiply solved it!:) $\endgroup$ – Tyler Dahl May 14 '18 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.