1
$\begingroup$

I keep getting these red dots on the whole render. How would I fix this?

I’ve tried increasing the samples, this I what I got when samples are at 500:

Red Dots

Any help would be greatly appreciated. Thanks!

$\endgroup$
  • 1
    $\begingroup$ Those dots are called fireflies. You need more samples....a lot more samples... see: Will increasing samples reduce fireflies? If you want to compromise on accuracy on the render you can use clamp indirect. see: blender.stackexchange.com/questions/1703/… $\endgroup$ – cegaton May 10 '18 at 18:32
  • 1
    $\begingroup$ In addition to more samples and clamping indirect, you can fiddle with the denoising setting in the scene settings. It will require a slight quality compromise, but it is possible to get good results and still use the denoise setting. $\endgroup$ – AlbinoPanther May 10 '18 at 21:40
2
$\begingroup$

What you are seeing are called fireflies.the fireflies are often caused by there not being enough samples for cycles to render with. I recommend upping the sample size you are currently working with.

There is also a really good article on other suggestions which you can try to reduce the noise.

7 Ways to get rid of fireflies

Additionally if all else fails you can also use the despeckle node which is used to smooth areas of an image in which noise is noticeable, while leaving complex areas untouched.

This works by the standard deviation of each pixel and its neighbors is calculated to determine if the area is one of high complexity or low complexity. If the complexity is lower than the threshold then the area is smoothed using a simple mean filter.

This will reduce the quality of your overall scene if your samples are too low however.

Despeckle Node

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.